ClubWRX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
Ok so I took my car to valvoline for an oil change and they said I needed a new air filter. So I told them to go ahead and put one in. Well the next day I'm driving I get on it and I can hear air being sucked in really loud. So I pop my hood and see that they didn't put my airbox back together right and it opened up. I was right down the street so I took my car back and they fixed. Now when I get on it it is almost as loud as it was when my airbox was was open but the box is closed. I was wondering if it could just be because I have a new filter or if there could be a hose or anything off. I looked but all I can see is the top and side of my airbox, I was wondering if there was anything on the bottom that may have came off or anything. By the way it's a 2010 wrx with a turbo back exhaust.
 

·
Registered N00b
Joined
·
263 Posts
I would have flipped the F out on those guys for messing up such a simple job that could have ruined your engine. And i would take it back to them to find the problem until youre satisfied and the problem goes away.
 

·
Captain James of the SS Impreza has gone down with
Joined
·
8,921 Posts
I would have flipped the F out on those guys for messing up such a simple job that could have ruined your engine. And i would take it back to them to find the problem until youre satisfied and the problem goes away.
His first mistake was taking it to Valvoline.

Them not snapping your airbox back together won't really do much other than let dirty air into your engine. The likelihood of your motor getting destroyed because of this is incredibly slim. The sound at this point is probably your paranoia.
 

·
Registered
Joined
·
4,033 Posts
Surprised this thread didn't start with this:

Ok so I took my car to valvoline for an oil change and they said I needed a new motor.


The bottom of the air box like clips together, it's possible that they didn't do that properly and when you look at it from the top, it seems fine.....or as Drews said, it's your paranoia. One of the two.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
I don't think it's my paranoia. I was getting on to the highway today and got on it and threw a code, not sure what it is yet but I'll check when I get home.
 

·
Captain James of the SS Impreza has gone down with
Joined
·
8,921 Posts
I don't think it's my paranoia. I was getting on to the highway today and got on it and threw a code, not sure what it is yet but I'll check when I get home.
Do you have an aftermarket intlet?
 

·
Premium Member
Joined
·
15,697 Posts
Look at the bottom of the airbox - get the two tabs to lock in.

It isn't easy really, you might have to take the hose off.

They may have taken the hose off and not tightened it back as well.

Your inlet may also be ripped at the turbo coupling.

Post the code as soon as you can. It isn't good to drive with a messed up A/F
 

·
Registered
Joined
·
115 Posts
Discussion Starter #8
If I remebered correctly the code was a P0103.
 

·
Lando Calrissian
Joined
·
3,787 Posts
P0103....Mass or Volume Air Flow Circuit High Input

Possible causes:
- Dirty mass air flow sensor
- Dirty mass air filter
- Mass air flow sensor harness is open or shorted
- Mass air flow sensor electrical circuit poor connection
- Intake air leaks
- Faulty mass air flow sensor


sounds like you likely have a leak in the intake......I would bet either bottom of the box is not sealed, or the hose is not secured to the box
 

·
Registered
Joined
·
115 Posts
Discussion Starter #10
Ok, so I finally had time to actually look at it. Those idiots put the filter in backwards and I don't know how to decribe it but there are like tabs on the filter and they were hitting the airbox not allowing it to close all the way. It's alot quieter and the box closes up a lot better. Still a little louder than before I changed it but I'm assuming it's because more air is getting through due to the new filter. Thank you guys for all the input I really appreciate it. We will see what happens from here, hopefully the problem is fixed.
 

·
Premium Member
Joined
·
15,697 Posts
You did see those tabs at the bottom and secure them? I was just *****ing about the design in another thread recently.
 

·
Registered
Joined
·
115 Posts
Discussion Starter #12
Yea I saw the tabs. The side that was closest to my engine was in, but the side I couldn't see that was up against my fender was out. So the airbox appeared to be closed but really wasn't.
 
1 - 12 of 12 Posts
Top