ClubWRX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter #1
Hey. For awhile now I've felt that my car wasn't as quick as it used to be, but just figured I was getting used to it's madness after owning it for a year and a half.

Here's the mods I have:

Invidia TBE
PDE Up Pipe
Uniflow Rampod SRI

I have the stock boost guage and did a conversion today from MPa to psi and found that I was pulling about 10.8 pounds of boost max in first gear. What the hell? Isn't stock boost supposed to be between 13-14 psi? I've never owned a boost controller, but I'm wondering if it's simply a matter of turning up the boost or if I have a more serious problem and am loosing boost. Why would this happen? Any thoughts?
 

·
Registered
Joined
·
223 Posts
Discussion Starter #3
Good to know. I wish I could see what boost I'm at in 3rd, but there's a little problem called the speed limit.
 

·
Registered
Joined
·
223 Posts
Discussion Starter #4
What is the optimal boost in 1st. gear if you have a boost controller. That is to say have a max of 16psi in 4th or 5th gear.
 

·
Banned
Joined
·
1,637 Posts
AwdTurboWrx said:
if i were you i'd tune it in 4th gear...dont you have a freeway or something?
Yep - that is the best way to do it. Set your boost at the max you want to run in 4th gear. That way 1st - 3rd will run slightly less boost. You can use 5th if you max your car out in 5th gear a lot, but I don't get the impression you do that - which is a good thing.
 

·
Registered
Joined
·
223 Posts
Discussion Starter #7
After doing some research I'm contemplating an EBC or the Cobb AP. An EBC is not necessary however with the AP because the AP automatically tunes the engine to optimal boost right? Or is is best to have both? Thanks in advance for your input.
 

·
Registered
Joined
·
5,825 Posts
if you get COBB AP ...than you dont need a mbc(or ebc)...which is a good thing...just remember you order cobb now you'll get your accessport in october probably
 

·
Registered
Joined
·
223 Posts
Discussion Starter #11
Ok. So I got on the highway and payed closer attention to my boost guage:

1st gear = .07 MPa = 10.15 psi
2nd gear = .075 MPa = 10.88 psi
3rd gear = .08 MPa = 11.6 psi
4th gear = as soon as it gets to .09, it drops to .08 MPa = 11.6 psi
5th gear = same as 4th

This sucks. Again I thought that the factory ECU sets the boost at ~14 psi in 4th and 5th gears. What could have caused this loss of boost? I only have 27,000 miles on the stock turbo. What should I do to fix it? I'm thinking the Cobb AP. Thanks for your thoughts.
 

·
Registered
Joined
·
1,356 Posts
a cobb ap might turn your boost up but its not gonna fix your problem, did you do the 3/16 mod? if so, did the "t" you used have a vacume restrictor in it (little brass thing), i had the same prob and this is what was wrong (previous owner did it) couldn't get anything better than a 15.0 1/4 time

.02c
 
1 - 12 of 12 Posts
Top