Subaru WRX Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
432 Posts
Discussion Starter · #1 ·
I know there are some spots already tapped on the block but the only ones I see are about 1/4" or smaller. I purchased a MSD knockalert, It comes with two mounting options for the sensor (1/4" and 1/2"). Also, the threads look too big to me.


Does anyone know of a good place to mount this sensor or will a have to re-tap to a larger thread?


The display unit itself is pretty ugly but everything seems well made. I will paint the box black instead of the ugly baige. This unit also fits perfectly in the ashtray spot. There is a slight void on each side though.

Any help?
 

·
Registered
Joined
·
432 Posts
Discussion Starter · #2 ·
Bump
 

·
Registered
Joined
·
432 Posts
Discussion Starter · #3 ·
Done

Well, after no help from vendors or the forums I tapped the block. Actually it was were the intake manifold meets the block in a pre-existing ground connection. I though about this for a while and thought that the exact spot shouldnt really matter as long as it is a solid connection to the block.
The knock sensor just basically picks up a specific frequency resonating through the block when knock occurs. After finishing up the electrical work I started the car and adjusted the sensitivity per instructions. No knock, couldnt even get the green lights to go(tried reving in neutral, and driving at part throttle/semi-high boost). The instructions did say that some cars that knock very lightly wont even light up the green even on the highest sensitivity.
So basically I have no way to know if this thing even works. Just a black box sitting under my dash. Maybe when my car is cold tomorrow morning I will get some slight knock on start up. Just something to tell me its working would be nice.
I guess I could look at bright side, my car just doesnt knock. But I'm very skeptical.
:rolleyes:
I may try tapping a spot closer to the actual cylinder heads. I guess when I get my UTEC tomorrow I will be able to compare knock counts.
 

·
Registered
Joined
·
1,895 Posts
To test the factory knock sensor on Lexus' the first step is to "tap with significant force" around the knock sensor area (not directly on the knock sensor).

i.e. Take a wrench and BANG on the motor with the sensor activated (powered). :D
 

·
Registered
Joined
·
432 Posts
Discussion Starter · #5 ·
Thanks for the tip is2scooby, that helped. I re-wired it and used the "tap" test to confirm the sensor was operating properly. Actually a very light tap trigger most LEDs on the display (sesitivity set at max). I think I had originally wired the positive side of the knock alert to another ground, I feel dumb. I have so many wires for my gauges, should have labeled them neg and pos.
With the sensitivity set to maximum, I had one green LED light up (very light knock) on start up for a second. Then no knock while idling or reving to 3000 RPM's in neutral.
While driving at WOT it lit most of the LEDs up, but that was expected set on the maximum sensitivity. So I dialed it down a little and dont have any knock unless I start to go part throttle/ high boost (which I never do normally).
I will be able to calibrate the knock sensor more accurately when I start data logging with the UTEC.
 

·
Registered
Joined
·
1,895 Posts
You're welcome and good luck! :D
 

·
Registered
Joined
·
5,095 Posts
hey good luck with that and let me know how it comes out because in the spring and summer months the mods will be coming in a lot since it's warmer out and i dont have a garage so it's driveway install. That is something i was looking to purchase so please keep me informed.
 
1 - 7 of 7 Posts
Top