Subaru WRX Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter · #1 ·
When I added the K&N drop in filter (which was a pain in the ass to fit but it fit) I immediately noticed LOST HORSEPOWER. this isnt normal is it?

the 1/8 mile track was open today hoping the ecu would adjust or something by the time i got there (50 miles after installing it) so i went to try it out.... and i was running consistantly 1-2mph slower than i should have been. but the lost horsepower wasnt just in the numbers, it felt much slower right away. i waited a lot longer for 2nd gear to reach redline. waste of $20 for the track :(


after 2 crappy track runs i tried it once with NO FILTER at all just to see how it would run and it ran slightly better but not yet as good as it was running when i had the stock filter on the day before. all i could think that this could mean is either 1) the engine doesn't like that much air (doubt this is it), or 2) the ecu is confused and still trying to adjust


on my way out of the track i reset the ecu and drove it hard... i think that it started to adjust itself to the k&n after a few pushes. it still doesnt feel like it's back up to it's former speed but i'm hoping it will adjust to it now and at least get back to the former power delivery. i HOPE it gets faster than it started like i had originally hoped, but if the car runs as fast as it did before all this i wont be too disappointed
 

·
Registered
Joined
·
555 Posts
Shiv of Vishnu offerred a quick way to reset the ecu. I can't find it, but it's recent (this week)...try a search under "Shiv".

I think it's the ecu still re-learning. Shiv said it could take between a few days to weeks (conventional reset) and he does a decent job of explanation some of the idiocycracies.

good luck.

BTW, I had my K&N for most of 6 months. It got a bit dirty so I removed...had a [email protected] of a time trying to get it back in...it was cold and I was frustrated, so i threw my oem filter back in...can't say I noticed any diff. That reminds me...I wanted to compare my mpg before and after....

Hg.
 

·
Registered
Joined
·
442 Posts
I saw an STi filter for sale for $100. A lot more expensive than stock or K&N, but I wonder if it would make a big difference. I can't remember where I saw it for sale.

Anybody know how the Perrin filter is?
 

·
Registered
Joined
·
8,886 Posts
very interesting, i was thinking about getting one, but for near $50 with this info and that it hasnt recieved great reviews from others i think ill pass
 

·
Moderating U!
Joined
·
4,192 Posts
I use a ITG filter, similar to the K&N, and I felt no such loss in horsepower.

Jim, have you taken out your silencer yet? You might want to try and take it out for increased air flow through the fender. That may help in unison with the drop-in.

Don't believe all dyno plots. Yes they may look good on paper, but most dyno plots just go from low range to redline, and not account for midrange and every day driving scenarios.

About the ECU reset, I will tell you from my experience. Since I use a Vishnu tuned Unichip, when I go to redline, I get a CEL. It has been well documented about Vishnu's unichip maps and CEL's.

Anyways, the last time at the track, my soft CEL turned into a hard CEL, and when I got home I decided to reset my ECU to clear the CEL. For the first gas tank, I only got 180 miles out of a full tank of gas. THe ECU was still learning and adjusting for my driving style. Needless to say, I beat the sh1t out of my car during that time, so it would give me an aggressive map. But the very next tank of gas I got near 260 miles to the tank, and still had a 1/4 tank of gas left. In short, it will take a tank or two of gas and a couple hundred miles for you ECU to re-learn your driving style.

Good luck Jim,

Kurlee Daddee
(THE ORIGINAL)
 

·
Banned
Joined
·
7,636 Posts
this seems to fall in line with the increase of lag, and general "butt dyno" decrease in power i keep hearing about with the install of a short ram.

anyone care to comment on this? my brother is getting me the AEM shortram (belated xmas present) and i'm now hesitant. i'd prefer he spend the money on something else if this is the case.

for what it'ss worht, i cna't justify spending $50 on a K&N, when i get a nice wix filter for $6 (or free from the store).

:shrug:

dR
 

·
Registered
Joined
·
153 Posts
hey dR, did you get the AEM short ram intake? wondering what your impressions are of it, if you have it, or have seen anyone w/ it. :)

marcus
 

·
Banned
Joined
·
7,636 Posts
haven't gotten it yet. like i said, i'm a little hesistant to put it in now with all the reports of increased lag, and decreased low end torque.

dR
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #11 ·
Well now that the ecu has been reset and I'm drivin around a little it's definately getting back some of the power it had lost before. I don't think it's fully as fast as it was before but I haven't drivin much yet either since the reset.

I still get the feeling that 2nd gear is taking longer to reach the redline than it used to.

I did mess with my AVC-R duty cycles a little, so the AVC-R has to re-learn a few things too, though I manually adjusted it to speed up the re-learning.

I'll update this in a few hundred miles. :p
 

·
Registered
Joined
·
196 Posts
I've had the K&N for about 2000 miles and havent noticed anything like this... I'm not going to say it increased HP, but I didnt notice a loss for sure...

:confused:
 

·
Registered
Joined
·
167 Posts
Discussion Starter · #13 ·
you just switched it and nothing like this happened? wierd that it would happen to me since i didnt expect it to happen

i havent done silencer mod or anything, if that matters. airbox is completely stock
 

·
Registered
Joined
·
196 Posts
My car has been absolutely stock except for the K&N... its weird that yours would be pi$$ed about the filter. Are you sure its seated properly inside the airbox? (not that this would create the effect you are describing, it just seemed time to resort to stupid questions :D )
 
1 - 14 of 14 Posts
Top