Subaru WRX Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Is this normal? Wastegate actuator problem? 4800 RPM "flutter" '17 WRX, 1,500 miles

I have been really loving this car so far but I have a couple of concerns now that I'm dipping into the power band more and more. The car is (obviously?) 100% stock.

As discussed endlessly, the stock tune in the '15-'17 WRXs has some quirks but I'm hoping you guys can put my mind at ease regarding how normal (or not) some of these quirks might be.

My two primary concerns seem like they could be both related to a waste gate actuator problem.

First, the power ramps up dramatically, as I believe it should, pretty low in the RPM band....but as I approach 5k, it falls on its face pretty hard and stops pulling all at once before seemingly fluttering back to life and pulling again around 5.2k to redline but not nearly as hard. I realize that these cars are known to have a strong mid-range and not much else...but is it usually a fairly dramatic drop off? What's up with that power drop?

Second, the boost gauge records your highest manifold pressure...I don't know what on earth I did nor when I did it, but the peak boost is reading "22.1." I always look at pictures of other owners' boost gauges in videos, etc. and I don't recall seeing anyone hitting a peak boost that high. Is this ok?

In both cases, an incorrectly functioning actuator could be suspect.

Any advice would be welcome!!
-Mike
 

· Registered
Joined
·
146 Posts
In my experience, and many other owners' of the 15-17 models, there is typically a power drop around 4500-5000 RPM on the stock tune. Many people flash the Cobb Stage 1+ or MAP performance Stage 1 tune through the AccessPort to mitigate this. Be warned though that doing so could lead to warranty claim issues down the line, as Subaru techs will be able to tell that this has been done.

As for the peak boost, mine always read 21.4 since the day i picked it up from the dealer. Recently, I noticed it increased to 22.2 after installing an axleback (whether those are related, idk). However, peak boost, to the best of my knowledge, is never sustained and only momentary, while your boost should even out around 15.8 or so during WOT.

So from what I've heard and personally experienced, i wouldn't be all that worried, as it all sounds fairly standard. But you are still under warranty, so it couldn't hurt to make an appt at the dealership if you are truly worried.
 

· Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
Thanks, Wrexic.
If this is typical (and safe) behavior from the motor, I'm sure I can learn to live with it but you're probably right that an appointment wouldn't be a bad idea.

I keep getting recommendations to pick up an Access Port but yeah...losing the engine warranty is still very unappealing at this point.

It's good to hear that your max recorded boost is up there too. If it was just an instantaneous spike, it seems like pretty silly information to have permanently displayed.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top