ClubWRX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I just got my 2012 WRX for about a month, and i notice this clicking sound whenever i start my car and take off. It only happens when the car has been sit for a while, meaning it wont make that sound when i stop for traffic light and go. Anyone else getting this? should i take it to the dealer ?
 

·
Registered
Joined
·
54 Posts
this happened to my 2012 wrx i got as well. It seems to be coming from the back right. I went to the dealer and they said it was a loose heatshield problem and they fixed it yet it still continued. I could not make sense of it so i went back the second time but could not reproduce the problem when they were trying to test it. They said it was normal -___-' please let me know if you have better luck..
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
thx guys, im just worried, cuz the car seems to be running fine and i am a nub for subaru and stick shift
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
they couldnt reproduce it becuz the car needs to sit for a while for that to happen, just by stop and go wont cost that
 

·
Registered
Joined
·
479 Posts
I have a 2011 and have the same sound. A bunch of us do, I actually think there's a thread on the forum about it. Nothing to worry about, just enjoy the new car.
 

·
Registered
Joined
·
9 Posts
mine has a wierd noise sounds like a low volume horn when I reverse then break.. its really annoying! But it picks its moments.. its not everytime i reverse..
 

·
Wants to Sell His Honyota Civilander..Any Takers?
Joined
·
785 Posts
I have a 2011 and have the same sound. A bunch of us do, I actually think there's a thread on the forum about it. Nothing to worry about, just enjoy the new car.
+1
 
1 - 12 of 12 Posts
Top