ClubWRX Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2,660 Posts
Discussion Starter #1
Hi this is Terri, Cameron's girlfriend. He is out of town until friday. I have been using his car for a month and today i went to go to work and it wouldn't start. Dash lights, radio, and headlights work. When I turn the ignition it makes a loud clicking noise. The headlights dim when i try to start it. The battery connections seem tight and clean. I have no idea. Everyone i mention this to tells me its the battery. But i know that he trusts you guys so i thought i would ask around. If someone could let me know that'd be great.

Terri
 

·
Banned
Joined
·
5,806 Posts
Hey Terri (this is Sam) Might be a dead battery if the lights work but dim when you try to start it... it might just need a jump? Let me know if you need help, I still live pretty close to you guys
 

·
Registered
Joined
·
374 Posts
Ah, the dreaded clicking noise. Ya, your battery is dead. You can jump it or push-start it. And don't listen to the B.S. warning on the jumper box, connect the Positive, then Negative. Start the car, and you can take the cables off.

Push starting requires more man power. Get 3 or 4 of your closest friends, and push the car to the top of a hill. Push it down the hill with the car in first and the clutch in. Build up as much speed as possible, and let go of the clutch. The car will start if you were going fast enough.
 

·
Registered
Joined
·
223 Posts
PyroManiac said:
Ah, the dreaded clicking noise. Ya, your battery is dead. You can jump it or push-start it. And don't listen to the B.S. warning on the jumper box, connect the Positive, then Negative. Start the car, and you can take the cables off.

Push starting requires more man power. Get 3 or 4 of your closest friends, and push the car to the top of a hill. Push it down the hill with the car in first and the clutch in. Build up as much speed as possible, and let go of the clutch. The car will start if you were going fast enough.
Or just have sam jump start it for you.
 

·
Registered
Joined
·
2,660 Posts
Discussion Starter #5
svc said:
Hey Terri (this is Sam) Might be a dead battery if the lights work but dim when you try to start it... it might just need a jump? Let me know if you need help, I still live pretty close to you guys
Thanks for responding guys. Sam, if you're not doing anything do you think you might be able to swing buy and help me out?
 

·
Registered
Joined
·
414 Posts
Terri,

get the car jumped and take it to somewhere like Checker/Pep boys/Auto Zone and have them check out the charging system (free). It could be either the battery or the alternator. Sounds like either the battery isn't holding a charge, the alternator isn't charging, or just a dead battery. The battery has enough juice to run things like the radio, the clicking sound is the starter.

Hopefully you just forgot to turn something off. If so, all is good once you jump it and run her for a bit.

Good luck.
:cool:
 

·
Registered
Joined
·
296 Posts
Zoombaru said:
I wouldn't recommend using another car to jump start it though. Take the battery out of the other car first, then use it to jump it. Either that or find someone with a battery charger and charge it over night.
Why would you not recommend using another car to jump the battery?

Nick C.
 

·
Registered
Joined
·
2,660 Posts
Discussion Starter #12
Thank you for all the help. Sam you're amazing. I turned it off and it started up again. So hopefully this worked. If (god i hope not) it doesn't start tomorrow, can i give you a call around 10:30 or so. Thanks again.
 

·
Banned
Joined
·
5,806 Posts
mike270 said:
Just curious, what was the problem?
The battery was really low, and just needed a kick. Cam's got those two electronic doohickeys by the rear view mirror, they might be drawing power from somewhere ? I don't know.
I <3 Cameron's wheels...and waist spoiler :cool:


Sure terri, give me a call if it doesn't start...it would be a great excuse to leave work!

And I never pass up an opportunity to jump start someone elses girlfriend
:tongue:
 

·
Registered
Joined
·
2,660 Posts
Discussion Starter #16
So the car officially sucks. It didn't work again this morning. It started to turn over but wouldn't go. So then i tried again, and more clicking. I think he's going to kill me.
 

·
Registered
Joined
·
2,660 Posts
Discussion Starter #18
Well, this is Cameron... I just got back from my month of hell. It was the battery. It had a bad cell so I just got it replaced.... Seems to be running fine now.... Thanks for helping Terri out Sam.

Hopefully, i'll have time for a cruise this weekend but I'm gonna be making up a weeks worth of homework and whatnot so it may be difficult.. Thanks again for all the help guys.
 
1 - 19 of 19 Posts
Top