ClubWRX Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
Hi all. I am a new WRX owner and my car just started making a weird noise. Anytime I rev about 3000 rpm it sounds like "shhhhhhh" and then stops when I shift. Any ideas what could be going on with my new baby?

Sent from my SGH-T989 using Tapatalk
 

·
Registered
Joined
·
67 Posts
Discussion Starter #3
Lol def not the turbo. It is a lot louder and I can also hear the turbo while this noise is occurring.

Sent from my SGH-T989 using Tapatalk
 

·
Registered
Joined
·
67 Posts
Discussion Starter #7
Took it to the dealer today. Turns out a hose clamp was loose. They tightened it and sounds great now. The dealer said its the second 2011 theyve seen recently with the same issue.

Sent from my SGH-T989 using Tapatalk
 

·
Good news, everyone!
Joined
·
3,856 Posts
That's what I was going to suggest checking, glad it was just a quick easy fix.

Best thing about a new car, is the warranty. Coincidentally, the worst thing about a performance vehicle can also be the warranty. :p
 

·
Registered
Joined
·
8 Posts
I have a 2012 with the same problem. Do you remember which clamp it was?

Took it to the dealer today. Turns out a hose clamp was loose. They tightened it and sounds great now. The dealer said its the second 2011 theyve seen recently with the same issue.

Sent from my SGH-T989 using Tapatalk
 

·
Premium Member
Joined
·
4,856 Posts
I have a 2012 with the same problem. Do you remember which clamp it was?
Old thread
But check your throttle body to Intercooler hose and clamps. That's more times then not the culprit
 

·
Premium Member
Joined
·
4,856 Posts
Thanks, still under warranty so I had the dealer fix it today! They even detailed my car..
I would recommend replacing it with a silicone hose too though. The stock one will tear, it may continue to slip off even after being tightened...The Inner flap glue or whatever wears out
 

·
Registered
Joined
·
8 Posts
I would recommend replacing it with a silicone hose too though. The stock one will tear, it may continue to slip off even after being tightened...The Inner flap glue or whatever wears out
Yea, the mechanic said he keeps those in stock as it happens a lot
 
1 - 13 of 13 Posts
Top