ClubWRX Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2,797 Posts
Discussion Starter #1 (Edited)
I have an 2004 JBP WRX and i have 4239 miles on it....the mods I have to my car are the Greddy EVO2 and a Blitz FATT...the 1st time i had to take it in was because cels were coming on and they said it was a code error so they had to send it to SOA to get it reflashed...For the past couple weeks i have noticed rough idle when the fans come on....like the car wants to stall and the rpm needle jumps all over the place...Wed. i took it in and they said it was the idle control valve so today(Friday 13th) the part came in and i dropped it off...They replaced it and i picked up my car and the1st thing i noticed was a fresh dig in my drivers door(the 1st one on the car and it happens at the damn dealer...Faulkner Subaru to be exact):mad: so they had to touch it up and i drove home....i didnt beat my car at all and when i go into the garage i let it idle for a lil to see if the rough idle would come back and it did...now the dealership says i have to rip off my TT and catback and put the stock one back on and they have to send it back to the factory...This has been the 7th time i have taken my car to the dealer for problems in 3 months and the car only has 4239 miles on it....Do you guys have any clue what could be causing this problem and how i may fix it....and if it is possible to claim my car under the lemon law since ive had sooo many problems

Thank Alot Guys....I Really Appreciate Your Help
Matt
 

·
Registered
Joined
·
109 Posts
i know this wont really help you all that much, but i would think about reading up on the lemon laws concerning new automobiles...
 

·
Registered
Joined
·
826 Posts
Go read up on the lemon laws for yourself. As for the problem I would not be mad at the dealer for asking you to pull the parts, as with a troublesome problem they have to at least revert the powertrain back to baseline. Just reset the car give it to them to fix.

(Now if you only had guages and a BOV but the rear diff was acting up I would say that is bs)
 

·
Registered
Joined
·
1,028 Posts
are you still throwing a cel code now?

Have they swapped the plugs? Cleaned your MAF with non-chlorinated brakleen? I think Bask Oner had a problem once where he was in a small fender bender and his cam jumped timing and his car wasn't running right.

I would start with plugs, and check your MAF, but since your car is so new, I wouldn't think you'd have those problems already but its worth a look. What did the dealer do exactly besides re-flash the ecu to troubleshoot the problem?
 

·
Registered
Joined
·
2,797 Posts
Discussion Starter #7
They replaced the headers and rear cat o2 sensor, reburned the ecu at SOA then friday they replaced the idle control valve
 

·
Registered
Joined
·
1,028 Posts
I would definitely check out the lemon law in your area, I believe here in CT its three times for the same problem and you can apply that rule.

Other than that, you could try and diagnose the problem yourself, but if the dealership is offering you warranty coverage by simply removing the exhaust and TT, I would try it. It's not like they're denying you coverage because of your mods. Why not just remove them and see if they can fix the problem and check out the lemon law in the meantime.
 

·
Registered
Joined
·
2,797 Posts
Discussion Starter #9
Well tonight I put the stock cat-back exhaust back on and Im taking it in tom mornin....so Ill keep you guys updated...thanx for the help
 
1 - 11 of 11 Posts
Top