ClubWRX Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hello,
My car is a 2010 WRX with 21k miles on it. Recently maybe 100 to 200 miles ago my car began to shake while in idle. It started doing it for a few seconds then stop. Now it does it more frequently and shakes more. Its not normal at all considering i know what the normal "Boxer" shake is. On top of this the rpm will drop below normal while idling and the car will almost bog out then the rpm go back up to normal, then above normal then back down to normal. This doesnt happen as often but its still occuring. The computer hasnt thrown a CEL so that isnt a help to me. Yesterday while the car was shaking a bit i pulled into a garage opened my hood and saw the engine moving more than i believe it should. I dont think the engine mounts would have gone bad already,and if it is that, whats up with the rpm jumps.
Any help would be a great!
 

·
Registered
Joined
·
1,839 Posts
Sounds like you might have a disconnected vacuum/boost line or a problem with the MAF or IAC or something. as said it should still be under warranty. I wouldnt touch anything, bring it to the dealer...
 

·
Æternum
Joined
·
20,595 Posts
Sounds like you have your A/C or Defrost enabled ;)
 

·
¯\_(ツ)_/¯
Joined
·
5,808 Posts
Sounds like you have your A/C or Defrost enabled ;)
Yeah, that was my first thought. :D

Sounds like its pretty bad, though. Definitely take it to the dealer. Maybe the AC compressor clutch is sticking.

Sent from my Droid 2
 
1 - 6 of 6 Posts
Top