ClubWRX Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
So my 02 WRX wagon throws out the code P1086. Checked and found it is the:
< Tumble generator valve #2 (LH) position sensor circuit low input >

Does anyone know where it is located and how to fix/replace it. It tried clearing the code but it does not happen.

Thanks!
 

·
Registered
Joined
·
15 Posts
So my 02 WRX wagon throws out the code P1086. Checked and found it is the:
< Tumble generator valve #2 (LH) position sensor circuit low input >

Does anyone know where it is located and how to fix/replace it. It tried clearing the code but it does not happen.

Thanks!
i have the same cel code, i took it to dealer, they told me i need to replace the whole tgv, the sensor its on top left of your maniflow
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
i need sensor # 2 wich is the sensor on the driver side
I have the sensor from the pessanger side, don't know if they are interchangable though. The dealer was selling the whole TGV unit for over $300 i think, and did not separately sell the sensors...bummer!!
If you can find the pessanger side works...then you'll be all set...
 

·
Registered
Joined
·
3 Posts
code p1086

hi i own a 2000 subaru wrx and got the same fault now do you think it might just be the sensor how easy is it to find one ,do you have a part number for that .Please help and also is it easy to replace or have to go to a mechanic

thanks
 

·
Registered
Joined
·
17 Posts
Discussion Starter #9
hi i own a 2000 subaru wrx and got the same fault now do you think it might just be the sensor how easy is it to find one ,do you have a part number for that .Please help and also is it easy to replace or have to go to a mechanic

thanks

It was easy to replace it myself...I just had to replace the left one...but I still have a right one, but it is for a 2002 WRX...
 

·
Registered
Joined
·
1 Posts
this is great

You guys are great with out this post I would have just replaced everything.

Subaru does not sell this part by it's self (t.g.v sensor)

thanks again.
 

·
Premium Member
Joined
·
132 Posts
I also have a P1086. Also tried clearing it, to no avail. I read the thread on scooby mods; http://www.scoobymods.com/tgv-sensor-cel-p1088-p1086-t5160.html

I see that the description for code P1086 says "Tumble Generated Valve Position Sensor 2 Circuit Low"

Where is sensor 2 located, by the turbo or the intake manifold?

Does anyone know what a 'circuit low' code means as opposed to 'circuit high,' P1087? Does it make a difference regarding what needs to be done to fix the problem?
 
1 - 14 of 14 Posts
Top