Subaru WRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello guys new to the forum seeking help . My 04 wrx keeps giving a reading of -11.95 on knock learn . I first thought it was bad gas but i have tried different stations and same problem . I have changed plugs coils filters checked for leaks found a couple and fixed them. Checked for exhaust leaks as well . I have 0 knock reading . My knock learning seems to only happen on low rpms because i get 0 on wot .also i rarely get cylinder 4 missfire . I did a compression test and everything seems to be in good shape . Anyone had this issue before?
Mods
Mishmotto radiator
Prosses west top mount
Perrin cai
Perring air and oil separator
Grimmspeed mbc
Bigger injectors
Dw300 fuel pump
Turbosmarts external westgate
Turbosmart recirculating bov
Unequal Headers
Wideband sensor
Ftb exhaust greddy
And a protune
 

·
Æternum
Joined
·
15,864 Posts
What does your tuner say?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Car was tunned in arizona i am currently in va i purchased the car tuned . It was fine untill a while back also getting like sputtering on boost than after 3 or 4 sputterings pulls hard. Maybe fuel pump is what realy just come to my mind
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Yeah some times i get cylinder 4 mosfire when that happens but is realy rare i have chaged plugs and coils fuel filter . Faulty fuel pump could cause misfire correct?
 

·
Super Moderator
Joined
·
11,451 Posts
So could a ton of things. I would start by checking for boost and vacuum leaks
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Checked for vac leaks found some and fixed them also replaced a bunch of hoses that looked dried or bad ended up replacing a good ammount
 
1 - 10 of 10 Posts
Top