Subaru WRX Forum banner
1 - 5 of 5 Posts

·
Registered
2009 Cobb stg2+ WRX
Joined
·
24 Posts
Discussion Starter · #1 ·
Okay, I’ll start with a list of mods, then go into a description of what’s going on…

Mods:
Cobb SF Intake (bought the vehicle with it…)
Accessport v3
Cobb Catted Downpipe
SPT exhaust (factory)
Stage 2+ Cobb OTS tune (93oct)
Mishimoto IC to TB hose
Reman engine (sharper edge)
Reman turbo (oem from rotomaster)
—-will be getting custom tune from eric (torqued performance) for the above mods and GS ebcs in a month.—-

If I didn’t mention it, it’s stock. The engine and turbo blew out and I didn’t have the choice over what went in…


Issues:

I encounter the occasional -1.4 fkl and the worst it was was -3.85 (been a while, and only saw this twice)

Feedback ranges from -1.4 (once every 5 to 10 minutes) to a few crazy -5.60, -7.00 and -8.40 readings over the course of 2 weeks. Been through 3 tanks of gas from 3 different pumps with 1 ecu learning reset on the last tank.
The second tank gave me the least issues (Valero)…. Most of this occurs when going uphill, 80mph on the highway in 5th gear, 50ish mpg on back roads in 4th gear, or 30ish in second gear.


Boost will not get past 13.55psi…tuned for 18.6. Found no leaks off visual inspection. Haven’t boost leak tested, and don’t know how…holds -9.25psi at idle

TD boost error and A/F correction values are all over the place…and AFR is slightly off. 14.7 idle, 9.9 to 10.5 when WOT.

and no, I haven’t had a CEL and my DAM has never dropped.



All in all, really just trying to get everything smooth…planing on replacing the fuel pump, filter, knock sensor, o2 sensors, and MAF sensor just to make sure everything is electrically sound on the sensor side.

please chime in with any experience or help. This has been an ongoing battle over the course of about 2 months.
 

·
Registered
2009 Cobb stg2+ WRX
Joined
·
24 Posts
Discussion Starter · #2 ·
Also, I don’t mean to sound noobish…I have looked up and down google, here, and nasioc for an answer, but am having a hard time deciphering. I don’t believe this is a compound issue, and have already ruled out a number of…odd possibilities…though I could be wrong.

when I search for info, I’ll get probable causes for one issue that don’t line up with the overall problem. My only thought is maybe the restrictor pill, but that doesn’t fully add up if I can still build boost…

dunno. Asking for experienced input. Thanks, all, in advance!
 

·
Æternum
Joined
·
15,935 Posts
Please post two logs.

1. Driving normally
2. A pull in 3rd gear ending at ~6000 rpm redline (be safe and judicious of public law)
 

·
Registered
2009 Cobb stg2+ WRX
Joined
·
24 Posts
Discussion Starter · #4 ·
Please post two logs.

1. Driving normally
2. A pull in 3rd gear ending at ~6000 rpm redline (be safe and judicious of public law)

okay, heres what we've got.

Logs - WRX - Google Drive

this is my google drive shared with 5 logs, each is labeled by their corresponding logs. [and yes, the top row is frozen]

The 3rd gear pulls are both done from first gear gradually to second, shift and hold third, and then WOT. I was not in boost in 1st or 2nd, and I pulled in 3rd straight to redline.

There is one with "normal" driving conditions, mainly 5th gear on highway, but i did include some variation in that one, plus a separate log of just 5th gear (no shifts) for about 10-15 miles on hilly highway ~70-85 mph.

The other one that is in there is where i actually captured knock twice. the first -2.80, and the second -7.00. ive got the rows highlighted in that one, and they are toward the end of the log (rows 7230 and 7655 respectively). i have noticed, when the knock does occur, its usually after driving twisty back roads OR (and this has happened repeatedly) i let the car warm up about 5 minutes before moving the car, drive for about 5-10 minutes, then the knock happens. its usually a small feedback between -1.40 and -2.80 first, then 20-30 seconds later a larger one, but then i rarely see knock again while driving, and never more than a -2.80.

Seriously, thanks for the response, and i hope someone has better luck deciphering than i do!! 😬
 

·
Registered
2009 Cobb stg2+ WRX
Joined
·
24 Posts
Discussion Starter · #5 ·
:::UPDATE:::

So, in an effort to dial in the issues I was having with boost, I upgraded to a grimmspeed ebcs and reached out to eric at torqued performance to get a custom tune for stage 2+ plus ebcs. While i was in there, i looked at the turbo inlet/wastegate "t" and found no restrictor pill....o_O needless to say, thats why my boost was off because it was causing the wastegate actuator to open prematurely (at a fixed pressure mechanically, regardless of target boost).

I have also experienced much less knock since the custom e-tune, though there are a couple areas where it lingers, usually shortly after warm up.
 
1 - 5 of 5 Posts
Top