Subaru WRX Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 · (Edited)
So I installed my GT Spec Header today, and mated it with my Godspeed uppipe.

I found out that my uppipe is leaking in 2 places, so I only fixed one of the leaks, still have a leak on the upper part of the uppipe, and an exhaust leak from mating my exhaust to my Invidia downpipe.

Fit was pretty decent. The o2 sensor barely fits, and the headers barely clear the frame but it fit none the less. The quality is very good. I only drove the car for 1/8th of a mile but it was a fun ride.

I am a stage II+, Cobb ECU, Uppipe, GTSpec Headers, Invidia Downpipe, Stock Catback, and I raced my friends stock Mustang Cobra up to 80mph and beat him by a car (he recently ran a 12.9 with a 1.9 foot 60 on street tires.)

Overall looks like once the ECU adapts to the new headers this beast should get me into the 12's on the stock turbo without nitrous.
 

·
Registered
Joined
·
1,535 Posts
Oo DaRk StAr oO said:
I am a stage II+, Cobb ECU, Downpipe, Uppipe, GTSpec Headers, Invidia Downpipe, Stock Catback, and I raced my friends stock Mustang Cobra up to 80mph and beat him by a car (he recently ran a 12.9 with a 1.9 foot 60 on street tires.)
So where exactly did you mount the second downpipe? :confused1
 

·
Registered
Joined
·
635 Posts
are those the equal or unequal length? keep the boxer sound? how much $ and where from?
 

·
Registered
Joined
·
1,637 Posts
WiCkeDrEx said:
If you can run 12s with stock turbo, you must got mad driving skills....
Not true. I ran a 13.3 with only a 1.9 60'. I also had some knock between 3rd and 4th, where the ECU was pulling timing really hard for about 1-2 seconds. I coulda ran a 13.1 with a 1.8 and no knock. That was with Stage II plus uppipe, base stage II plus uppipe map (untuned). I don't consider my self an awesome driver, by any means. I'm still learning :wiggles:
 

·
Registered
Joined
·
1,637 Posts
Oo DaRk StAr oO said:
I can't wait to run this setup. The addition of the ECU and headers with new tires should help me out a lot.
We'll see. I know with my S-03's, I couldn't launch for **** cus they were TOO sticky! The RE92's are good for drag racing :wiggles:
 

·
Registered
Joined
·
600 Posts
RLsChMiDt said:
Not true. I ran a 13.3 with only a 1.9 60'. I also had some knock between 3rd and 4th, where the ECU was pulling timing really hard for about 1-2 seconds. I coulda ran a 13.1 with a 1.8 and no knock. That was with Stage II plus uppipe, base stage II plus uppipe map (untuned). I don't consider my self an awesome driver, by any means. I'm still learning :wiggles:
Then I think my driving skill needs to be improve or something. With the mods that I have I should be running in the 13s, but the best I pulled was 14.3. I know the BOV is making me lose some power. Also, my car is at the dealer getting my tranny fix. Could tranny be the reason for me to lose power?
 
1 - 14 of 14 Posts
Top