ClubWRX Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
596 Posts
Discussion Starter #1 (Edited)
i changed my oil last week, and i noticed yesterday that i can see oil around the edge of the oil filter. and then there was oil around the drain plug. so i bought a new filter and a new plug with gasket. and today the same thing is happeneing. what the hell can be wrong? over night there was a small spot of oil on the gound where i park. i thought maybe last week i over tightened the filter, so this time i hand tightened it, and i didnt tighten the plug as tight this time either. i really dont know what else to do, anyone have a suggestion?

also im using a fram filter, would that maybe be the problem for the filter? i still dont know what to do about the oil near the plug
 

·
Registered
Joined
·
956 Posts
I put my filter snug not tight have sceen no problems.
 

·
Registered
Joined
·
596 Posts
Discussion Starter #6
i tightened the plug up with a breaker bar, it definately needed to be tightened. and i also tightened the filter up a little bit. i drove it about 20 miles, and i just checked it, no oil leaking from the plug anymore, but theres still the visible oil around the edge of the filter. im guessing its suppose to be like that because its not leaking out or anything its just a thin line around the edge. im gonna leave it for now and see what both look like tomorrow
 

·
Registered
Joined
·
16,991 Posts
TgoWRX04 said:
i tightened the plug up with a breaker bar, it definately needed to be tightened. and i also tightened the filter up a little bit. i drove it about 20 miles, and i just checked it, no oil leaking from the plug anymore, but theres still the visible oil around the edge of the filter. im guessing its suppose to be like that because its not leaking out or anything its just a thin line around the edge. im gonna leave it for now and see what both look like tomorrow
A little oil around the outside edge is fine I'm sure. You probably fixed it this time...

Does everyone replace their crush washer with each oil change? I haven't done an oil change on the Rex yet and I'm thinking about buying some FHI filters/washers..
 

·
Registered
Joined
·
1,184 Posts
I also saw this problem when I changed my oil. Just need to tighten things a little bit more.

I also went to the fumoto valve after the oil change to get rid of the pesky problem.
 

·
Registered
Joined
·
218 Posts
did you coat the oil filter gasket with a thin coat of oil before you installed it? It keeps the gasket from binding and creating a crease that could leak oil. Also I would recommend a different filter. This is personal opinion but the fram has cardboard endplates as opposed to almost every other filter manufacturers metal endplates. I haven't really heard of any problems using frams but I think they are crap. I use the Puralator Pure one which in my opinion is as good as they come.
 

·
Registered
Joined
·
498 Posts
typically that will happen around the oil filter.

you only need to hand tighten a new oil filter on when you do an oil change because the oil heat causes the rubber around the oil filter to seal into place really tight.
 

·
Registered
Joined
·
1,184 Posts
I used Purolator and it did leak a little, but it was just because it was not tight enough. I just compared the one from Sears. Looks like the Purolator and Sears brand are similar.
 

·
Registered
Joined
·
5,207 Posts
Its a good idea to change it each time ( crusher washer) because i have changed the oil with out it and it leaked, and every time i do use one it dosnt leak so i would advice to chance it each time just to be safe.
 

·
Registered
Joined
·
120 Posts
i use genuine subaru filters and it comes with the crush washer... i've heard it could do some damage if you don't change the washer! but i change it every time... with the filter i just tighten it till i feel it's good enough... they say 3/4 turn is good but mine is probably more like a little over 1 full turn with oil rubbed around the rubber gasket!
 

·
Registered
Joined
·
1,078 Posts
TgoWRX04 said:
i tightened the plug up with a breaker bar, it definately needed to be tightened. and i also tightened the filter up a little bit. i drove it about 20 miles, and i just checked it, no oil leaking from the plug anymore, but theres still the visible oil around the edge of the filter. im guessing its suppose to be like that because its not leaking out or anything its just a thin line around the edge. im gonna leave it for now and see what both look like tomorrow
WHOA there tiger! BUY A TORQUE WRENCH! The point of the crush washer is LESS torque for a good seal.

-Jim
 

·
Registered
Joined
·
60 Posts
Did you remove the old crush washer? The first time I changed my oil, I did not remove the old washer. It was painted black and stuck to the oil pan so I did not see it. Just a thought.
 

·
Registered
Joined
·
1,578 Posts
i've had no problems using my same crush washer (keep forgetting to get some). i just did my 15k change.
i always fill and coat the new filter when installing it and follow the mfg direction on tightening the filter. no leaks.

as for oil filters, i use Puralotor PureOne filters. if you look for the filter that fit's the '04 STi, it's the same as the new smaller filter from Subaru.



SUBARU OE OIL FILTER: 15208AA080
PUROLATOR OIL FILTER: L14612
FRAM OIL FILTER: PH6607
WIX OIL FILTER: 51365
K&N OIL FILTER: HP-1008
AMSOIL OIL FILTER: SDF13
AC DELCO OIL FILTER: PF1237
 
1 - 17 of 17 Posts
Top