ClubWRX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Hi all.
Attempting to run the power wire for my new amp, I managed to pop the grommet (on firewall near brake) into the engine bay. It didn't fall to the floor. Is it sitting on a "shelf" in there somewhere?

I can't see it. Anyway to get to it?

('04 wagon)

Thanks a bunch!

BC
 

·
Registered
Joined
·
167 Posts
If I had to guess I'd say take out the windshield washer fluid holder, i think it's just 2 screws. There's more info on here somewhere too.
 

·
Registered
Joined
·
4,016 Posts
Woody182 said:
If I had to guess I'd say take out the windshield washer fluid holder, i think it's just 2 screws. There's more info on here somewhere too.
yep...and maybe one of those doo-dads from the store that reaches into thin places
 

·
Registered
Joined
·
826 Posts
Actually the odds are that you can see it, try getting some bright flashlights and shining into the corner. If you can see it on the shelf then disconnect your power, and use a wire coathanger to push it off the shelf.
 

·
Registered
Joined
·
1,302 Posts
yup did the same as you. used a straightened out coat hanger with the other end at a 90 degree angle. reached around and ..... woila! grommet was on the driveway.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #7
Thanks for the ideas, peeps!
I'll try that. (had to go to a pool party so I have to work on it later)
 

·
Registered
Joined
·
13,126 Posts
Next time you have trouble, try removing the engine block and everything else from the engine bay before trying to retrieve the part you're looking for.

Good luck in the future.


-Josh













:eek3:
 
1 - 12 of 12 Posts
Top