ClubWRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
The time has come for me to voice my problem with Godspeed. I have held off to this point for fear that he would become even less motivated to resolve my issues. It is now apparent that it is not possible for him to become less motivated.

For more details please see http://www.pegdrgr.com/godspeed_sucks!.htm
Also the links below will take you to the e-mails between us.

The basics:
Late in March of this year I decided to purchase a GT30R turbo kit from Dan. I was looking for one of the early GT kits, and Dan seemed to have a great setup. After spending a couple weeks talking with him I placed my order. Dan promised me the kit by the end of the first week in April.

I did not get my first parts until JUNE! In order to get those parts I had to threaten him with cancelling the order and making him promise to ship me the parts, and get me a tracking number. Even after making that threat several times he did not ship me all my parts. The ones that I did get had issues, numerous issues. After trying to work with him I determined that I was never going to get parts that would work, let alone make me happy.

I have included all e-mails between Dan and myself in that link and below. Please read them. The only modifications I have made is I blocked out my name and my e-mail address since it is a work address, and the price I was quoted on a motor I ended up not buying. All changes are in red.

The short list of issues includes items such as:
1. A hole in the up pipe that was Jethot coated
2. Female to female V Band clamps on the up pipe
3. no O2 bung in the downpipe for the rear O2 sensor
4. No support to hold the turbo
5. Missing V Band clamp
6. Missing turbo to IC adapter
7. 3/8" barbs fittings for 1/2" hoses

There are a total of 12 items that were wrong with the kit at the time I first received it. For a kit that was $3,800 and over 2.5 months late that is totally unacceptable. Dan did over night me some of the parts, however we agreed he would send them all the first day, he did not. In fact at the end of the week he had only sent me 1/2 the parts. Instead of letting me know that 1/2 the parts had not been sent he just kept silent.

That was it for me, I cancelled the order. Dan said he understood and he would refund my money as soon as he got the parts back. I send him all the parts, packaged up better than they were when they were sent to me. My reward for this was he refused to give me all $3,800 back. Instead he claims he can not refund my money on the coating or the shipping. I am not returning this kit becuase I changed my mind, I am returning it becuase it does not work, will not work, and is approaching 3 months past it's promised delivery date.

Here are some pictures of the items that were wrong about his kit.








 

·
Registered
Joined
·
956 Posts
not sounding good...

yet "God" has not responded on here to show whats up? maybe it's a good thing I did not get the down pipe after all if what you say is true.
 

·
Registered User
Joined
·
4,769 Posts
Sorry guys just saw this. This kit (before it was coated) was test fitted on my STi so it did fit and fit very well. In fact we have some pics I believe of the kit installed. We ran into a problem with the return line for some reason due to the hose being a slightly different size but the actual pieces did fit if assembled correctly. You can not use the flaged bolt on the uppipe. You have to use regular bolt and stud for it to clear the uppipe. Yes it is a tight fit. Everything is a tight fit to clear everything else in that engine compartment. Since we designed it on the STi we did not realize the cruise module had to be relocated. We will make sure anyone with a WRX knows this before shipping anything in the future. The hole in the uppipe baffles me. We welded the uppipe inside and out as we have our regular uppipes for years using a Miller Synchrowave 250DX TIG aircraft welding unit. I still have not figured it out yet but we are inspecting all the other uppipes we already have made to make sure nothing comes back from the ceramic coaters with a hole in it. I apologized to Jarrod and told him that the $200 for coating it will be returned if I can grab an extra uppipe from GT Spec so I can make it into a regular coated header. I did return $3500 for the kit the day I received all the parts without any delay and without any questions. I didn't even inspect everything to make sure it was all here as I'm sure Jarod was in a hurry. Fact is these kit will provide a level of performance not yet seen on a WRX/STi and we will check the quality very closely to make sure nothing defective ships out from here again. JUst to clarify we overnighted a regular non coated uppipe to use until we could remedy the defect with the ceramic coated one. We did this at our own expense.
 
1 - 4 of 4 Posts
Top