ClubWRX Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1


So it started when I failed an inspection the other day for wipers and fog lights. My wipers were torn a little at the ends and the fog lights, even though they had both worked about two weeks earlier, wouldn't come on. So I have two weeks to fix them and come back. I checked the fuses to make sure nothing was blown and I picked up new wipers and bulbs.

Now the trouble starts.

I tried to change my bulbs today. The first bolt came out very reluctantly. On the second one I leaned into it so much I broke the socket extender. I got a different extender and decided to try a bolt on the other light. The first one I tried gave a little bit before I snapped the head right off of it.



Does anybody know a good way to get the rest of the bolts off? I have an '02 and live in the Northeast so they are a little rusty.

Also, what can I do about the broken off nub of a bolt?

And what damage can I do driving around with only two of the three bolts holding the light on?

I only have a little over a week to figure this out and I don't want to have to pay somebody for this.

Thanks for any help.
 

·
Is in Love With the Admins Here
Joined
·
2,770 Posts
I guess I would just do what I had to do to get the remaining bolts out. I would've sprayed them a few times with PB Blaster or WD40 first though if they were rusty. You can get new bolts from the stealership. As far as the broken socket goes, buy Craftsman. :thumbup:
 

·
Registered
Joined
·
2,082 Posts
No clue about the '02. I have a different fog problem. I bought my '06 in Sept. of '06 and I've had 2 blown fog bulbs already. I can't remember if it's the same side that blew twice. The body shop fixed the first one when my car got keyed, I need to check the estimate.
 

·
Is in Love With the Admins Here
Joined
·
2,770 Posts
I have a different fog problem. I bought my '06 in Sept. of '06 and I've had 2 blown fog bulbs already. I can't remember if it's the same side that blew twice.
My 04 has a bad problem with blowing fog lights & low beams. Although this problem started after I switched over to Silverstars. The funny thing is, I've had Silverstars in my Legacy for over a year w/o any problems. Weird.:confused:
 
1 - 5 of 5 Posts
Top