Subaru WRX Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
I know the brochures and everything else mention 15.9 psi. I'm pushing 23.2 (according to the head display). Is this normal with an untuned WRX?
 

·
Super Moderator
Joined
·
11,417 Posts
The 15 plus WRX seems to show boost spikes of over 20psi. If you are maintaining this pressure there may be a problem, but from the number of times I've seen this asked and the lack of blown up fa20 posts here I'm going to assume it is normal for that engine.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #3 ·
Oh nice. The techs and service writer didn't mention anything regarding a turbo issue. I brought it up to one of the sales people and she just looked at me puzzled, like, "how the hell did you manage an extra 8psi without messing with it?" I still remain amazed


Sent from my iPhone using Tapatalk
 

·
Æternum
Joined
·
15,855 Posts
It's normal.

Sent from my SAMSUNG-SM-G890A using Tapatalk
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #5 ·
It's normal.

Sent from my SAMSUNG-SM-G890A using Tapatalk
Oh ok, so advertised numbers are off from the factory? I thought maybe someone toyed with the ecu or boost before I got it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
63 Posts
My '16 will record spikes of up to mid-23 PSI fairly regularly. It occurs right as I shift when going hard thru the gears.
My dealer has a service tech that eats. drinks & breaths WRX's and said it was normal as a short "none load" condition.
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #7 ·
My '16 will record spikes of up to mid-23 PSI fairly regularly. It occurs right as I shift when going hard thru the gears.
My dealer has a service tech that eats. drinks & breaths WRX's and said it was normal as a short "none load" condition.
Yeah, I see it quite regularly going through gears in turns driving in the mountains. Quite impressive power gains I've noticed


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
129 Posts
like XJ and the others have said, that is likely the peak boost reached momentarily while spooling up, but i'm sure it evens out around 15-16PSI. Mine personally has peaked out at 22.2
 

·
Æternum
Joined
·
15,855 Posts
Oh ok, so advertised numbers are off from the factory? I thought maybe someone toyed with the ecu or boost before I got it.


Sent from my iPhone using Tapatalk
No, it's a boost spike from questionable boost control strategy.

The advertised numbers are from steady state operation. If you were to log your MAP during spool, you would see the spike subsiding to a steady state of expected "boost" after perhaps 200ms. Subaru clearly decided that this spike did not put the motor at risk of failure.

FWIW, the same spike happens in the STI as well, albeit not as extreme.
 
1 - 10 of 10 Posts
Top