Subaru WRX Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
In the morning for the 1st minute or so, the car will run pretty rough on cool mornings. Also at about 90mph I can smell exhaust. At Idle I can hear the engine pinging..does it sound like I need to get the ecu flashed?
Also the dealership said they hadn't heard of the sti's pinging and refused to send it in to be flashed, they said they considered it a mod. He also tried to say that pinging is normal for that car. The only thing he said I could do was leave the car with them to check it out but I'm almost positive they still wouldn't send it in. What should I do, get ahold of s.u.a? Or is there some documentation of the pinging problem that I can show these guys?
thanks,
jared
 

·
Registered
Joined
·
1,053 Posts
1st Your dealer is full of idiots and or *******s. Go to another dealer and contact SOA if you want.

2nd I have never heard of a car pinging at idle if it was it should probably blow up while driving it, are you sure you arent hearing the valvetrain noise that is typical of the flat 4's? Pinging occurs when the engine is at its peak load, such as wot at 4-5k or going up hills or flooring it while in to low of a gear. If it happens at idle it wouldnt last through any kind of load

3rd as for the exhaust I dont have an explination I havent noticed any smell at 90mph.
 

·
Registered
Joined
·
85 Posts
would the silencer box reduce pinging noises?
coz i can hear wastegate flutterint noise when engine is at load at high gears
but it's gone with the silencerbox back in
 

·
Registered
Joined
·
1,053 Posts
Those noises are what the silencer is designed to silence. But they have absoulutly nothing at all to do with pinging.
 

·
Registered
Joined
·
85 Posts
coz everyone heard pingings once a while, i never did, i want to know if i ignored the issue
maybe i should try find sound clips of pingings
 

·
Registered
Joined
·
841 Posts
cann said:
no no
i mean i never hear a ping on my car
how does it suppose to sound like?
You will know when you hear it... It is a horrible horrible Knock! and your dealer ship is on crack! F**N Ediots! I agree go to another dealer and talk to them.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #8 ·
My problem is that there is only that 1 subaru dealership in the entire state. Maybe the car isn't pinging afterall, I figured thats what the fluttering sound was at idle. Off idle the car runs great. Tonight when I started it, it was idling below 500rpm and sounded like it was going to stall if I didn't tap the gas, is that a common problem?
 

·
Registered
Joined
·
1,053 Posts
Nitro700 said:
Tonight when I started it, it was idling below 500rpm and sounded like it was going to stall if I didn't tap the gas, is that a common problem?
Only if your bov is loose or you have a leak in your system. Are you sure it was idleing at 500? you know the middle line on the tac is 750 and the little line right above 0 is 500.
 

·
Registered
Joined
·
1,053 Posts
You dont "tune" a stock bov?

I had a stipped bolt on my bov on my wrx some time ago and it would cause the car to stumble and eventually die if I didnt give it gas and sometimes die even if i did give it gas.

But anyways Im assumming your car is compeltely stock correct? You thought your car was pinging but it is actually not so you may not need a reflash anyway so there is not a need to deal with your dealers being idiots at this time.

Now your car seems like it is going to die but it has never actually died? Next time this happens dont give it gas and see what happens there may be no problem at all but check your fitting on your turbo, inter cooler, intake manifold, and bov just to be sure nothing is loose because any of that could cause stumbling at idle.

And you will know if your car is pinging it will be unusal sound such as marbles dropping into a can or somthing popping in your engine. It will not be a continous sound like you are hearing at idle.
 

·
Registered
Joined
·
85 Posts
oh yea
i'm assuming he has a aftermarket bov
all aftermarket bovs will cause stumble at idle and rev fluctuate under idle except gfb bov, which has ways to tune it and adjust it and eliminate that stumbling

so if it's really the bov, go with the gfb stealth
 

·
Registered
Joined
·
1,053 Posts
Thats just mis information. Thereis more then one bov that will not cause stumbling. The only ones that cause problems are the 100% atmospheric bovs that are not adjustable. Any recirculating bov will run just fine and any adjustable ones can be adjusted to recirulate enough to run just fine.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #15 ·
Thanks for the replies guys.
The car is completly stock, the low idle only happened once..if it happens again I won't tap the gas and see if it stalls. Overall the car seems to be running perfect lately. The fluttery idle just had me nervous.
On another note, my breakin is almost up and I need to get a new filter..do I need to go to the dealership? Napa only has up til 2003 I think. Should I run the synthetic mobil1 or stick with the conventional
thanks again
 

·
Registered
Joined
·
1,053 Posts
Get filters from the dealer you are not going to find any better filters elseware. As for synthetic or dino oil its a personal choice. Some people swear you need dino oil untill 8k and some say put synthetic in immediatly neither side really has conclusive proof.

As for me on the first oil change I just let the dealer do it because its free. On the second I go to synthetic usually mobile one, but amsoil and royal purpal are usually tested to be better, but they are more expensive and you usually have to order it.

Your idle flutter was probably just a change in temp from the last time the car was on and the ecu was adjusting.
 

·
Registered
Joined
·
120 Posts
In a way the dealerships are being gay...but at the same time its because they all have recieved bulletins from s.o.a. saying they arnt doing anything about pinging/knock/det... yet! I keep trying and s.o.a, they keep telling me to deal with it. I cant take my knocking anymore. I feel like the car is just gona blow up if i dont drive like a granny! How did some already get the reflash...and why does Turboxs and vishnu both say that the utec WONT fix the pinging...they say since our ecu's have learned the pinging, it wont get rid of it...even if you disconect your battery! FREAKIN HEADACHE!! i want to do so many mods but im stuck until i get this stupid thing figured out!:( :mad: :confused:
 

·
Registered
Joined
·
1,053 Posts
rayn4eleven said:
How did some already get the reflash...and why does Turboxs and vishnu both say that the utec WONT fix the pinging...they say since our ecu's have learned the pinging, it wont get rid of it...even if you disconect your battery! FREAKIN HEADACHE!! i want to do so many mods but im stuck until i get this stupid thing figured out!:( :mad: :confused:
The reflash came out a few months ago and soa released a bultin aobut it saying the car will have to be left at the dealer while the ecu is shipped to get a reflash.

Where did you hear that the utec cant fix pinging? The utec is not out yet and vishnues xede is and it has stopped pinging and increased power considerably.

Oh well glad my car doesnt ping even in texas heat.
 

·
Registered
Joined
·
120 Posts
afpdl said:
The reflash came out a few months ago and soa released a bultin aobut it saying the car will have to be left at the dealer while the ecu is shipped to get a reflash.

Where did you hear that the utec cant fix pinging? The utec is not out yet and vishnues xede is and it has stopped pinging and increased power considerably.

Oh well glad my car doesnt ping even in texas heat.
when ever i call the dealer or even SOA they tell me they arnt reflashing...infact they arnt doing anything about it at all...and even infact, everyone ive talked to hasnt even heard of the problem at first...and then after confirming, says theres nothing being done right now.
i was told from a local import shop who looked into helping me correcting my pinging with other than dealership answers...that he's talked to the guys from turbo xs and vishnu...and they dont guarantee anything as far as correcting the pinging...and i know it sounds stupid...because in theory, thats exactly what it should do!
anyway...my biggest concern right now is that i never felt the knocking before i got my boost control...im wondering if i even have the same "pinging" everyone else has! I beat on my car just as much before my added boost but never felt it...now i get it alot!:(
what im geting feels like a sudden buck like a fuel cut for a split second when im flooring it in a downshift at high end...check engine light comes on and cruise control blinks...and it takes forever for it to go away.
anyone got an answer...is this the same thing anyone else gets? is this "knock"? Maybe i have a totally wrong and distorted view of this:confused:
 
1 - 20 of 23 Posts
Top