ClubWRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So i purchased a 2002 WRX Impreza that was STI swapped and i am trying to figure something out. I went through emissions and the guy said it couldnt connect he said “connection is loose” i mean at most the DLC was just not mounted properly just dangling (Wiring was good). Im thinking it might have something to do with the engine light not turning on but regardless i have a BT OBDII and i can read the code as well as one from work and i can still read codes. Codes that pop up are P0327/P0328.
Any idea to what this could be im really struggling trying to figure this out!
 

·
Moderator
Joined
·
10,686 Posts
Its a code for the knock sensor. Its either bad, or disabled. I'd bank on the later.

Try replacing it, or clearing the stored codes and driving a while. if that doesn't work then you'll need to find a tuner that can work on the car and figure out why its disabled.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Its a code for the knock sensor. Its either bad, or disabled. I'd bank on the later.

Try replacing it, or clearing the stored codes and driving a while. if that doesn't work then you'll need to find a tuner that can work on the car and figure out why its disabled.
So i figured what it is thank you for the lead Turns out previous guy did a custom tune and got a Cold Start delete would it be best to detune it by myself or is it more complicated than that for it to require me to go to a Tuner
 

·
Moderator
Joined
·
10,686 Posts
Tunes are taylored to the specific vehicle and it's modifications. If you are capable of tuning a vehicle sure, if not find a tuner
 
1 - 4 of 4 Posts
Top