ClubWRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey I was just wondering if any one had any thoughts on my intake side vac line blowing off, spitting oil every where inside engine bay resulting in hot oil dripping on plastic skid plate starting a fire? A guy driver past happened to have a fire extinguisher so i could put it out. I had it in the shop three weeks ago to correct an issue with oil being cycled into my intercooler piping. I drove it home 270 miles and here and there since then. I got it out saturday and thats when all this happened, Started with codes being thrown, called the shop they said reflash computer reinstall tune and take it for a drive that is when the fire happened. I had it towed home I put the hose back on so I could put it in the garage and now I have one hell of an engine knock as well . What do I do? They told me to leave it as is and trailer it to them so they can work on it/ fix it . I guess I'm just wondering what other people thoughts were! Thanks
 

·
Pro Manscaper
Joined
·
21,455 Posts
Wow...quite an issue.

Let's start with the obvious: What are you driving, and list all your mods. Can't really help without knowing that.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
2010 WRX:

- COBB ACCESSPORT
Protune
GRIMMSPEED Subaru Boost Solenoid
KARTBOY SHORT SHIFTER
Kartboy SHIFTER BUSHINGS
WALBRO FUEL PUMP 255LPH
BLOUCH TURBO TD06H-20G-XT
DOWNPIPE DIVORCED POLISHED STAINLESS STEEL
GT SPEC DOWNPIPE
PERRIN FRONT MOUNT INTERCOOLER/ TUBING
Injector Dynamics ID1000 top feed injector
PERRIN TURBO INLET HOSE
Big Maf Intake

I am currently running 21 lbs of boost .
 
1 - 3 of 3 Posts
Top