ClubWRX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
433 Posts
Discussion Starter #1
Does anyone know where I can find the recommended alignment specs for the 02-03 Eibach pro kit? I want better specs than the stock because Ive heard they are not that great. Is there a site that offers these? Also, I drive mainly highway but possibly plan on autocrossing in the future so if anyone has any suggestions on toe/camber/etc. settings it would be greatly appreciated.

-Griffin
 

·
Registered
Joined
·
433 Posts
Discussion Starter #3
Sorry, had to help my pops do some lawn work :(. Little OT but how'd it go? Hopefully everything went pretty smooth?

Anways, I was reading a post about alignment specs on prodrive springs and a couple people didnt think that stock were necessarily the best way to go.

http://www.clubwrx.net/forums/showthread.php?s=&threadid=73480&highlight=alignment+specs
Don't even consider the stock alignment specs. They are garbage for any kind of spirited driving. GARBAGE. Stick with the Prodrive settings or search around for some performance driving oriented specs.
-Griffin
 

·
Moderating U!
Joined
·
6,318 Posts

·
Registered
Joined
·
629 Posts
Boosted4 said:
Sorry, had to help my pops do some lawn work :(. Little OT but how'd it go? Hopefully everything went pretty smooth?

Anways, I was reading a post about alignment specs on prodrive springs and a couple people didnt think that stock were necessarily the best way to go.

http://www.clubwrx.net/forums/showthread.php?s=&threadid=73480&highlight=alignment+specs


-Griffin
it took us a little time but it went well now it seems to want to over heat . someone told me to burp the system but i dont know what the mean by that do you....
 

·
Registered
Joined
·
433 Posts
Discussion Starter #6 (Edited)
it took us a little time but it went well now it seems to want to over heat . someone told me to burp the system but i dont know what the mean by that do you....
Yea, sometimes when you flush the coolant system and try and add new coolant when the engines cold, it wont actually let it pass through because the thermostats not open. You can actually just let it run for a little bit so it heats up and then add the coolant. You could possibly have an airbubble in the system also. That happends quite a bit when the coolants flushed. I think theres a couple posts about it. Ill find 'em and let you know.

-Griffin

Here it is: http://clubwrx.net/forums/showthread.php?s=&threadid=71316&highlight=coolant
 

·
Registered
Joined
·
419 Posts
I went with -1.0 camber up front and kept -1.3 camber in the rear. I kept toe at 0 all around. I have Eibach pro-kit springs and a Cusco rear swaybar (set to the middle setting). I still have a small amount of understeer but I can get the rear loose by braking in a turn.

The only thing that I'll change next time I get my car aligned is to increase the front camber to -1.3 (or as close to that as it will go).
 

·
Registered
Joined
·
598 Posts
i had my alignment with prokits set to -.8 F/ -1.0R camber and 0 toe. you want more camber upfront than the rear if you want more oversteer.
 
1 - 10 of 10 Posts
Top