ClubWRX Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
this may not sound like a problem but all ive read here is that unless you have a cel fix or a engine management you throw a cel when you install and uppipe and downpipe. well i put an hks uppipe and downpipe on my 04 wrx a couple days ago and have about 220 miles on it since then and still have not thrown a cel. is this bad?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
i mean obviously its not bad that i dont have a check engine light on but i just want to know what you guys think
 

·
Registered
Joined
·
144 Posts
well thats good u didnt...im not sure if u are suppose to thro a code or not...i just got my 04wrx..how did u like the up and down pipes? u install ur self? did u notice a gain in performance?
 

·
Registered
Joined
·
5,825 Posts
my car didnt get a cel for like 250-300 miles(also with hks uppipe/downpipe)..than it threw cel's...you'll need a mil eliminator for the downpipe and a resistor for the uppipe....or you can get some sort of ecu management


if you end up not getting a CEL..we can call this a miracle
 

·
Registered
Joined
·
2,301 Posts
i'd say just go with engine management, perhaps cobb stage 2 accessport, it will get rid of the cels (if they show) and gives you some more horsepower:D

kinda pricey, but worth it in my opinion

btw--welcome to the club, its kinda nice and kozy here
 

·
Registered
Joined
·
5,825 Posts
bluerex47 said:
i'd say just go with engine management, perhaps cobb stage 2 accessport, it will get rid of the cels (if they show) and gives you some more horsepower:D

kinda pricey, but worth it in my opinion

btw--welcome to the club, its kinda nice and kozy here
sorry but cobb pisses me off..order cobb now and get it by october..forget that crap
 

·
Registered
Joined
·
461 Posts
You'll need engine management eventually to clear an up pipe CEL. The resistor fix doesn't work forever (so I'm told).

The down pipe fix is really simple though. You can get a set of spark plug non foulers from the auto parts store that will screw into the bung. Go get HELP! brand spark plug non foulers part # 42009 or 42002. Drill out tip of one with 1/2" drill bit. Screw them together and then into O2 bung hole on pipe. This creates an extension to move the O2 sensor back.
The only difference in the part numbers is one of the sets is tapered, and the other is not. Either will work just make sure you drill out the top one to 1/2" so the sensor doesn't bottom out.

More info, search on "mechanical cel fix".
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
thanks for the tips guys. yes i did know a good difference in the performance i have 2 and a half inch piping past the downpipe. i only noticed a slight drop in torque it feels like. but waaaayy better top end and spool up is way faster plus the exhaust now sounds mean and my turbo whistles loud as hell. which is a good thing. i plan on ordering accessport and recieve it in 2006 but its cool. how well do those cel fixes work like the one on the vividracing site
 

·
Registered
Joined
·
5,825 Posts
well i have the ponyexpress mil eliminator ..and have had it for a while no problems..i got the resistor mod for uppipe..still no cel's with either


btw...have you gotten a cel yet?? if not.dont bother till you get it
 

·
Registered
Joined
·
294 Posts
ok i have the turboback exhaust from turbo xs and when i installed i put the sensor back into the cat pipe but there was a place for a sensor on the downpipe.. I dont have a CEL yet but im just wondering why its there..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #12
going on 300 plus miles guys and still so cel. maybe my cel dash light doesnt work lol. by the way has anyone ever had some hesitation that feels like low boost only till about 5k rpms and then it feels like you get full boost back?
 
1 - 12 of 12 Posts
Top