ClubWRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
So I first noticed my dash illumination lights as well as the illumination lights for the radio and dash where out so i replaced the #12 fuse and it did the trick... lasted 2 days and they where out again...

Replaced it again and it only lasted one trip.. and l couldent find the problem nore the time to look into it further so for like a week ive been poping a new fuse in every trip that requires night illumination...

just the other day i noticed that the fuses blew almost immediatly and so did a 20A (it takes a 10A regulary)

Now even with a perfectly good 20A fuse (im outta 10A and using 20A just for troubleshooting the problem, ill grab some 10's in the morning) in the socket there is no lights!

Where should i check? any diagrams available for this? perhaps a common problem?

I could use any help at all really!
 

·
Registered
Joined
·
0 Posts
check all wires for a short
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
check all wires for a short
Are there diagrams available somewhere.. id imagine since there seems to be no power at all and the fuses arent being blown anymore.. but the illumination lights for dash, radio, and nobs all arent working then I can save some time by starting where all the lines come together as one...

that is if i explained that well enough
 

·
Registered
Joined
·
161 Posts
same problem

ya i have a 06 wrx and am having the same problems that you are with the dash dimmer lights did you ever figure anything out or find out how to tell if a wire has a short any info would be great thanks
 

·
Registered
Joined
·
161 Posts
update

so i finely figured out that It was the Integrated Unit. I pulled it out from under drivers side dash, yanked out the ckt board and found a spot on the board that looked fried. I soldered in a jumper and put it all back together and whoalla! Dashlight

Guy over on nosioc had the same problem thanks to him
 
1 - 7 of 7 Posts
Top