Subaru WRX Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter · #1 ·
Does anyone have DIY instructions for the Defi Gauge Pod and Defi Gauges? I have Boost, EGT, Oil Temp and that control unit comes with it. Any help would be very appreciated. Thanks.
 

·
Registered
Joined
·
258 Posts
I have the same gauges. You may want to try a search on here and the I club for installing them but I will give you a fast rundown.

Boost,
I have my boost tapped off the blow off valve and the sender unit mounted by the battery.

Oil temp,
I have the adaptor thing that mounts between the oil filter and engine. Make sure NOT to use the extension that came with the adaptor or the temp will be off.

EGT,
I have mine about 3" off the heads on cyl. 2 & 4. There is a debate as to which cyl. is the leanest but this one was the easiest to get to. I had a shop tap into the manifold, cost about $180 or so.

I put the little control unit where the ashtray used to be. I don't exactly like how I have it in there now though. I just pulled out the ashtray and shoved it in there, you can still see the ashtray rails.

I ran all of the sensor wires through a hole in the firewall just behind the clutch pedal.

You will also have to pull apart the trim around the radio. It just pops out of place. You may have to remove the cup holder though. And it is easier if you pull out the sterio,( I did but didn't unplug it) so you can get the wires up to the gauge pod.

For power, you will have to unplug the clock when you remove it from the dash. Look on the back of the clock and there will be all of the wires you will need for the gauges. Use the "vampire" clips and it is really easy. The only thing is the gauges don't dim with the dash but that is a minor gripe.

It was a fairly easy install, I took my time so I would say it took me about 4 hours to do (not including the EGT).

[email protected]
 

·
Moderator
Joined
·
895 Posts
when you're installing 3 gauges (or even more) how do you tap into the existing wires behind the stereo to get power/lighting to them? do you just share the wires, or do you have to find different outlets for each gauge? i connected mine the way the subaru instructions say, the wires protruding from the cd player.
 

·
Registered
Joined
·
307 Posts
Discussion Starter · #4 ·
So I have everything in now, I just need to hook up the power and lighting stuff to the defi control unit, the colored wires from the clock are blue, black, blue/pink, and yellow/green and the colors from the control unit are red, white, orange and black. What are the correct matchings for these?
 

·
Registered
Joined
·
307 Posts
Discussion Starter · #5 ·
I'm all set with that now. One other thing. When I hook up the boost sensor do I just T joint it off the tube of my TurboXS BOV? CUz it's a smaller tube than the turboXS tube and i didnt know if it would slow down some flow or something...
 

·
Registered
Joined
·
258 Posts
no it should be fine.

Penguinking, if you have the Defi gauges you will only have 1 set of "power" wires comming off of the control unit. You will connect them to the clock wires (If you are installing the pod where the clock used to be). Just read the instructons of the Defi gauges and read the back of the clock when you remove it. It will all make sence!

[email protected]
 

·
Moderator
Joined
·
895 Posts
Akiata said:
no it should be fine.

Penguinking, if you have the Defi gauges you will only have 1 set of "power" wires comming off of the control unit. You will connect them to the clock wires (If you are installing the pod where the clock used to be). Just read the instructons of the Defi gauges and read the back of the clock when you remove it. It will all make sence!

[email protected]
thanks! but i have autometer gauges :D is it still the same though? like, mine didn't come as a kit, so its different

- sorry about the confusion there
 

·
Registered
Joined
·
15 Posts
wiring question

hey guys i just got my bf gauges... fuel pres, boost and egt... i was wondering about the mounting of the control unit... where did you guys wiring in the unit.. if you could tel me what wires you used it would be very helpful


thanx ed
 

·
Registered
Joined
·
3,478 Posts
1 - 9 of 9 Posts
Top