Subaru WRX Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
51 Posts
same here..help!

The same thing happened to me today. Yesterday I flushed the coolant and I am absolutely sure I did it correctly. I've done it on other cars before. Now today it started to wave up and down and then just as I got home (downhill) it shot up to the H and stayed there.....till I turned the car off and hoped I wouldn't hear a huge **crack** as the engine shattered into 3000 pieces. I checked the coolant level in the reserve tank and it seems fine. I am going to wait until it cools down and open the radiator cap and put some more coolant and water in if that is low.....then we'll see..maybe run the car while it is still open and keep adding water until I see no more bubbles. Let me know if you got your problem fixed?
 

· Registered
Joined
·
51 Posts
2 problems

Yeah..I found out that I lost the small rubber gasket that is in the drain plug. And on top of that I had air in there bigtime! I fixed the air problem but the gasket still leaked so I used a ziplok bag over the plug and screwed it in real tight. Hopefully that will get me until tomorrow when the replacement gaskets come in (3 bucks apiece shipped from Portland overnight). We'll see!
 

· Registered
Joined
·
51 Posts
Problem Solved

Yes, the small rubber gasket can be had by ordering it from your local Subee dealership for $3.10. I also got a spare drain plug as it is likely to crack someday being made out of low quality black plastic.I thk that was around 6 bucks. Put it in, no more leaks. Got all the air out, no more overheat......whew...
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top