ClubWRX Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey everyone this is my first time using this site, so please bear with me, i have JDM 1996 STI I recently blew my head gasket and replaced it with a cometic head gasket, and since doing my car will just not start, the injectors keeps getting flooded with fuel and the car just wont start, is that the cometic head gaskets are not compatible with this particular car, cause i have seen replacement of head gaskets being done on models from 2002 upwards... Any information as to what i can do will be greatly appreciated
 

·
Registered
Joined
·
633 Posts
Did it ever start after the replacement? Did it start flooding right off the bat? What mods do you have? Are the spark plugs going off?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
cometic head gasket

Car is completely stock, never started since the replacement, and its just constantly flooding with the injectors, yesterday we tried starting with just one injector and it sputtered for about 3 seconds and then shut off again, and yeah all the sparks plugs are going off.... even had an electrician check all the electrical components and still it would not start .. what i was wondering was if the cometic head gaskets could be throwing off the timing
 

·
Registered
Joined
·
633 Posts
Did you try new plugs? I don't know what exactly you did when you replaced the gaskets... but are the injectors dirty? maybe stuck open, causing it to just dump a bunch of fuel?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
ok i have tried new plugs new coil packs, new injectors, tried few other ecu's.... tried new sensors, basically we took another car of the same model and tried everything from the prefectly working car and placed them in mine and it just wont start... and when we tried all the components from car and placed them in another car... it works .... so right now i am just stumped
 

·
Registered
Joined
·
1,019 Posts
Are you pumping the gas pedal when you are trying to start the car?
 

·
Registered
Joined
·
1,019 Posts
Have you tried changing out the fuel pressure regulator?

You need to make sure those injectors are pulsing properly. Might need an o-scope.

Also is that ECU the proper one for the JDM STi? Where are you located?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
yeah tried changing the regulator... whats an o scope? .... and the car has the correct jdm ecu in it ... my location is jamaica...
 

·
Registered
Joined
·
1,019 Posts
O scope is short for oscilloscope.

So I do not know for sure if the gaskets are causing your problem. It sounds to me like there is some sort of tuning issue going on. Do you have a local tuner out there. Shoot I am not even sure if your ecu is even tunable. One time my tuner helped a guy over on the islands they had a hard time tuning.

Are you sure all your grounds are properly grounded?
 
1 - 10 of 10 Posts
Top