Subaru WRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hey guys , so recently i bought a 06 wrx and this last 3 days when i press the clutch to go to first gear it makes a squeak sound and when i am letting the clutch go and accelerating it makes the same noise.It makes the noise when i go from first to second gear but I really dont hear it when is in third gear.

I dont know what could cause this, i recently bought the car from one of my friends dad, and his dad is a tech and he rebuild the engine and put a new clutch and new wheel bearings. I also let the car warm up for like 6 min, also i dont know why but the fuel gauge acts up too like goes from top and the straight to E and then it shows you how much fuel you got.

Before i forget the car was sitting for 4 years and he said it could be that the car was sitting for so long that the gauge is acting up. Also the check engine light comes on with the cruise control light so i took a wd scanner and it gives me this code PO463.

I apologize if i wrote to much, but does anyone have a idea what are the problems?

Bruno
 

·
Super Moderator
Joined
·
10,901 Posts
I believe that code has to do with the fuel level sensor. It would explain the gauge. The sensor is probably bad from sitting.

The clutch squeak. Is it from the pedal, or the clutch itself
 

·
Registered
Joined
·
11 Posts
My clutch squeaked when I would engage and disengage it as well, however this happened intermittently and the tech I spoke to mentioned it could be throw out bearing, slave cylinder or a number of other things but most likely at my current mileage It just needed some lubrication, which they did and I haven’t heard it squeak since.
 
1 - 4 of 4 Posts
Top