Subaru WRX Forum banner
1 - 8 of 8 Posts

·
Moderator
Joined
·
433 Posts
Discussion Starter · #1 ·
Ok so since around 3000 miles I've noticed this 'repetitive clicking' noise whenever I start off in first when the clutch bites. After I'm going in first or in 2nd and above..the noise is gone. I have no grinding gears of any sort, but this clicking bothers me. It's coming from (the engine I would guess) in the direction of behind the speedo/tach. It's starting to bug the living crap out of me. Any idea what it is? It's not particualrly loud, but my wife can hear it when I tell her it's doing it, so it's not just me. I showed Subaru and they could hear it but didn't want to mess with anything until it got worse ("if it got worse" - they said) If anyone knows what it is so I can get it resolved, I'd be eternally grateful.

Thanks..
 

·
Registered
Joined
·
1,629 Posts
You're stock. Go to the dealer and ask the service manager.

Not to be a dork, but even if I (or the service tech) heard the offending noise in person, probably neither of us would have any clue what the problem is. Doing it over the internet is absolutely imposible.

But if I were to guess, your sppedo cable needs to be lubed. At least that's what I would have said "in the old days". That's probably not true now.

misterx
 

·
Moderator
Joined
·
433 Posts
Discussion Starter · #3 ·
They have no idea, as I said above. Grrrrrr...guess I'll just turn the radio on louder :(
 

·
Registered
Joined
·
1,095 Posts
Ask the dealer to check the belt tensioner.
Common problem.

When is Subaru gonna issue a recall for this? sooo many people with the same deal.
 

·
Moderator
Joined
·
433 Posts
Discussion Starter · #5 ·
Hey PKer give me more information! Belt tensioner? Describe to me what it does and what is going wrong with mine. Then I can tell Subaru!
 

·
Registered
Joined
·
2 Posts
What it might be

I have done some research on my cars noise, more than likely its the clutch or the belt. For me, the noise occurs when the clutch isnt touched, but the clicking happens through all of my gears. I figured its either my clutch fork arm or front bearing going to the input shaft. Noise in 1st & 2nd gear only however sounds like the gearbox since it doesnt click when its idling?
 

·
Moderator
Joined
·
433 Posts
Discussion Starter · #7 ·
Holy thread back from the dead, Batman!

I haven't had this issue in a long long time! It went away one day and has never come back. I'm on 30k miles now :)
 
1 - 8 of 8 Posts
Top