Subaru WRX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter · #1 ·
I'm pretty sure I hit fuel cut this morning. Got a momentary shutter with the CE light illuminating. Cars running fine just had a momentary shutter. I'm still playing with my Joe P boost cont and it Got pretty cold here last night. My gauge read just over 17psi just prior to having the problem. I’ve questioned the accuracy of my boost gauge from day one. Looks like I may have been correct. My question is, will re-setting the ECU clear the CE light? If not, does anyone know what jumpers need to be made to clear it?

Thanks,
Shawn
 

·
Registered
Joined
·
44 Posts
Disconnecting the battery should clear the check engine light. It will put your ECU back in learning mode. The car won't run as good for ~20 miles or so. I have the OBD-2 software and cables to pull codes and clear them. Highly recommended if modding a WRX.

Later,

Dale
 

·
Registered
Joined
·
554 Posts
When I was tuning in my MBC I got CELs also. I went to the dealership and was told it was a code for the wastegate. I was just hitting to much boost. Turned it down half a PSI and no more problems. When I floored it on the freeway, I would get a big thunk, loss of power, then CEL. Get back on the gas and it was acting normal, except thr light stays on. Also I noticed about 3 starts of the engine would reset this light. Just turn down the MBC and you should be OK.

Good Luck,
Justin
 

·
Registered
Joined
·
66 Posts
Discussion Starter · #6 ·
Thanks for the replies. My CE light was solid, not blinking. Pulled the neg battery lead for 30 min and all was well. Turned boost down a tad to prevent any future CE lights.

Shawn
 
1 - 6 of 6 Posts
Top