ClubWRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,272 Posts
Discussion Starter #1 (Edited)
Well. I know this isn't normal. Currently my stock 2005 WRX has been making clacking noises while struggling after 5k RPMs.
This is on a stock tune. First learning view is for the stock map:
LearningView-Stock.jpg
I've read that its apparently known that the stock map is tuned for emissions rather than performance/dependability so here is the LearningView with and OSECU OCT91 stg1 map, not recent but timings are more or less the same:
LearningView-OsEcu.jpg
Its just retarding really bad right around 5k underload for both maps
and lastly here the best 3rd gear pull I could get on the 405 freeway =P
View attachment Last run.csv.txt
For now I'm just gonna set the rev limit to 5k until I know whats up.
Any suggestions on where I should look at next?

Some extra factoids:
Burning ~1qt when driven mildly-hard to hard
123k miles
Just checked the intercooler and found oil in the intercooler and throttle-body. Cleaned it and ran alright don't remember if it clacked for not on that run.
Have a feeling the intercooler might be too dirty and IAT(125*F) are too high possibly causing a the pinging(if it is pinging)
I will be looking at the plugs this weekend to check for oil.
Has all scheduled maintenance

Thanks ya'll.
 

·
Premium Member
Joined
·
15,697 Posts
Yeah, it is probably audible. A bit like rattling a paint can?

Anyways, it is obviously knocking excessively. Don't do any more hard pulls until your IAM comes up.

Is this on multiple tanks of gas and are you going to the same station all the time?

1 qt. of oil (I assume you mean per change) is not excessive.

You should do a compression test while you have the plugs out.

I don't believe your intake temp is sufficient to cause this.

I'm wondering if you have a clogged injector or something.

It is a bit questionable on the stage I map they have the D cell A/F learning disabled. It isn't really indicated by your A/F learning, but clean the MAF and check for leaks in the intake before the turbo. It wouldn't hurt to do a boost leak test as well.

I can't read the log as a text file.
 

·
Registered
Joined
·
1,272 Posts
Discussion Starter #3
Yep, thats it. Rattling paint can noise.

That stock AIM has been learned for about a few months, so probably as high as it'll get. OSECU map has been on for a few days. Everything is stronger, just past 5k is still bad.

I see where you're going with this, last tank was at the Shell near home vs Shell near GF place.

Sorry, its ~1 qt ever 1000 miles.

Probably will do the compression as soon as I can. I don't own a compression tester.

I've ran fuel injector cleaner less than 1000 mile ago. But it was cheap. I'll try running it again.

Funny they would have that disabled, is this common practice? I've check then cleaned the MAF when I was under the hood yesterday checking the intercooler. In the process of building a boost leak tester, been a pain to find parts that fit...

and just take off the txt extension, the file is a csv but the forums doesn't allow it.

Thanks for the advice so far man.
 

·
Premium Member
Joined
·
15,697 Posts
Maybe they have a loaner compression tester at autozone etc.?

I think some people disable it as if it learns to pull fuel in that cell it can apply that to WOT and cause potentially lean conditions.... however if it needs to be adding fuel because of an air leak between the turbo and MAF it can't learn to do that. It doesn't seem likely looking at the stock learning though.

When you get the plugs out take a good close picture of each. Also look with a magnifying glass for little spherical metal deposits on the electrodes.

If compression testing and looking at plugs doesn't reveal anything, it would be worth it to go to a shop with a wideband 02 meter.
 

·
Master Baiter
Joined
·
22,114 Posts
UEDan said:
just take off the txt extension, the file is a csv but the forums doesn't allow it.
In the future, just upload the file to Google Docs (be sure to make the document "Public")
 

·
Registered
Joined
·
1,272 Posts
Discussion Starter #6 (Edited)
In the future, just upload the file to Google Docs (be sure to make the document "Public")
Probably will man, like most forums, the 1.5MB limit is nothing...

Anyways, just wanted to use this thread as my own update/upkeep log.
Haven't been able to do any checkup due to school/work.
Might be due to bad gas. Drove it down to the fill-up light then went back to my regular Shell station. Still pinging, but now it has moved to 6k. Probably some left over from the last place.

Yesterday, had to fill up near school. randomly picked 76, whole damn car felt so much smoother. Idle is better too.

DAMN YOU CALIFORNIA PISS GAS! Always a hit or miss....
 

·
Registered
Joined
·
1,272 Posts
Discussion Starter #7 (Edited)
Problem solved.
Clogged uppipe.

Apparently the Clacking/clicking noise was the turbo.
Dealership checked it out, turbo luckily wasn't killed by the turbo.

Charging laptop now. Gonna put on OSECU Stage 1 map on the dealership lot =P
 
1 - 7 of 7 Posts
Top