Subaru WRX Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey guys just got a hatch 2012 maybe 2 weeks ago. She currently has 167k on it and is completly stock. Yesterday when leaving from work i noticwd my check engine light was on and traction control, plugged it into my brothers accesport to see the code and it gave me a P code saying i had a miss fire in the 3 cylinder. Deleted the code and went for a drive and the car didnt show any issue.... today leaving from work again check engine was flashing this time and came off after 2 minutes...? Does any one have this issue? I tried the trick where you can get the codes from the dash and it gave me (c0057,c0047,c0042) but there are no p codes.
 

· Not a mod... or is he? Or, is he not?
Joined
·
15,782 Posts
Yeah, you have a misfire. I would check for intake and boost leaks, plugs, exhaust leaks, maf, O2 sensor just to start

Sent from my SAMSUNG-SM-G935A using Tapatalk
 

· Not a mod... or is he? Or, is he not?
Joined
·
15,782 Posts
If you are unsure I would look for a shop in your area that is comfortable working on Subarus. It's not painfully difficult and there are hundreds of how to videos on YouTube so if you want to take a stab at it you should be fine.

There are a few common leak points, including factory top mount around the plastic end caps, turbo inlet, intercooler to throttle body hose, the tumble generator valves, as well as the turbo to intercooler connection.

Is the car modified at all? You mentioned you had to borrow an ap to read the codes. However if there is any modifications like an intake, turbo back exhaust or upgraded top mount getting the tune will be the top priority as it can cause misfires and engine knock that will kill the engine dead.

Sent from my SAMSUNG-SM-G935A using Tapatalk
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top