Subaru WRX Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter · #1 ·
i was going to change my tranny and rear diff fluid this past weekend, but i ran into a slight problem. i was reading the instructions on how to do it on the wrx...but the STi is a little different, since there is the diff temp sensor there. am i just supposed to use a huge crescent wrench to get that thing off? (the one to add fluid). anyways, just wondering if anyone has done it so far.

the reason i want to change the fluid is ever since i got my car back from the dealer (when they fixed my broken rear halfshaft), i get this loud hum/drone at 35 and 65mph coming from the back. so i just want to check and change the fluid back there to see if that resolves anything. anyways, thanks in advance. :)
 

·
Registered
Joined
·
6 Posts
2 screws to unbolt. The small one where the sensor is, and one on top for letting air in for faster drain. After all the oil are drained, you could fasten the one at the bottom and start pumping new oil in thru the openning on top.

Not sure if i remember it right, I have done it long time ago.
 

·
Registered
Joined
·
312 Posts
Discussion Starter · #3 ·
actually, the larger one has the sensor...thats the one on top. the one on the bottom is the regular 1/2" driver bolt. i dont have a wrench big enough to fit around the top one...im wondering if there is a trick to it...
 

·
Registered
Joined
·
6 Posts
No, you don't unbolt the big nut, there is a smaller one attached to the big o nut, you want to unbolt that one instead.
 

·
Registered
Joined
·
312 Posts
Discussion Starter · #5 ·
worked well, thanks for the help.

on another note, the fluid in there was gross. sludgetastic. glad i changed it...recommend people change theirs, too.
 
1 - 6 of 6 Posts
Top