ClubWRX Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
473 Posts
Discussion Starter #1
I took my car to my uncle who is a mechanic yesterday and he just called me today telling why my car threw a CEL. He said that my exhaust gas sensor was reading higher temp. gases and threw a CEL and that my intake was the case for this. Would my SPT Intake w/o a heatshield do that? Anyone else experience this?
 

·
Premium Member
Joined
·
11,095 Posts
I took my car to my uncle who is a mechanic yesterday and he just called me today telling why my car threw a CEL. He said that my exhaust gas sensor was reading higher temp. gases and threw a CEL and that my intake was the case for this. Would my SPT Intake w/o a heatshield do that? Anyone else experience this?
It would help to get the actual code from your uncle.

It could be your Up-pipe having issues in which case you want to fix that.

Or it could be a faulty sensor. Your intake doesnt really have anything to do with your EGT.

They've been known to screw up some MAF readings but the SPT intake is usually pretty good (in comparision).

Do you have any other mods? If you are in warranty take it to the dealer. I'm fairly certain in CA the Up-pipe/DP (along witih your turbo) is covered for something like 10 years.
 

·
Registered
Joined
·
473 Posts
Discussion Starter #3
no i have no other mods besides the intake and a megan racing boost gauge.
i was just told that the CEL went away and it might come back on. ill try to get a code when it does. thanks
 

·
Registered
Joined
·
473 Posts
Discussion Starter #5
uhm....he probably said it was the intake because it was the only mod that "might" some how affect it. he said the CEL went away when he drove it to the shop and that it might come back on.
 

·
Registered
Joined
·
112 Posts
I do failure analysis and root-cause is determined by factual evidence vice probability. Just because the intake is your only mod does not make root-cause of the CEL absolute.

It can be one or, a combination of, several parts like ([email protected] stated in his post) that are the root-cause of failure. That is why I asked how your uncle came to that exact conclusion...
 

·
Registered
Joined
·
6,751 Posts
Oiled intakes frequently cause CELs. It may or may not have done it in this case, but either way, if I were you I'd take it off the car. It's not going to give you any power, especially since it's a short ram aka hot air intake.
 

·
Registered
Joined
·
473 Posts
Discussion Starter #9
i installed it myself a little over 2k miles ago. i'll try to get the code pulled when i get the car back from oil change.
 

·
Registered
Joined
·
560 Posts
Post codes. The SPT intake should be fine.

Or maybe your uncle put the MAF sensor in backward.
not sure, but don't think the car would run with it in backward...I only say this from an experience I had about 5 years ago on a subby....the car idled rough for about 5 seconds then died. The intake installed had the MAF bung welded in backwards!

The Code it threw would help. You have 3 sensors that MIGHT throw this CEL (I say might as I don't know the code it was):
-The egt sensor in the upipe
-The O2 sensor in the exhaust manifold (behind the passenger front tire)
-The O2 sensor in the Turbo-back exhaust line (behind the catylitic convertor)
-Or the ever-present oiled air intake possiblility...
 

·
Registered
Joined
·
473 Posts
Discussion Starter #11
alright. i'll definitely check those out. thanks alot for everyone's input! :thumbup:
 
1 - 11 of 11 Posts
Top