Subaru WRX Forum banner

Car Wont Start after Fuel Mods, Help!

2285 Views 20 Replies 7 Participants Last post by  AHildebrand13
Went ahead and completed installing 725cc injectors, cobb fuel pressure lines and performance pump. After everything is done I primed gas lines and went to turn on now car wont turn on seems like fuel wont go past the new regulator. Any ideas, thanks Car is a 15 STI.
1 - 20 of 21 Posts
Did you already flash the map?

Sent from my SAMSUNG-SM-G890A using Tapatalk
Yup flashed before I tried to start up
I'm starting to think it's the regulator any way to check to see if it's functional, is it suppose to be free flowing?
Did you replace the O-Ring on the fuel pump?
You know what I think I used the old o ring...
Did you put back the fuel pump fuse?

Sent from my iPhone using Tapatalk
Yes fuse is back in place. fuel makes it to the lines but not past the regulator, like if it won't open to let gas flow to injectors
What regulator are you using? You sure the feed and return lines are plugged into appropriate locations?

Sent from my iPhone using Tapatalk
I got the cobb fpr kit yea its pretty straight foward on the install.
Could the o ring on the pump be causing that.
I think if fuel is making it to the fpr and no further I'd be looking at the fpr

Sent from my HTC One M9 using Tapatalk
When I undo fuel lines from firewall gas gushes out and nothing comes out on the other end after fpr
Updated removed fuel pump assembly inspected everything replaced o ring with new one. Still won't start. There's one thing I removed tgv motor on passenger side, is there a certain way to reinstall
Fixed!! thanks for all the info and help!
Would like to know how you fixed it. What was wrong?
Feel like a dumbass after working all day on it fuel lines were installed wrong... I know...I managed to install injectors in less time than others... but lines something so simple... I had the same look(your avatar) on my face when I found out lmao!!!
Lol feed and return lines swapped?

Sent from my iPhone using Tapatalk
Yea out of all things, glad it was just that. Now for disconnecting the battery I'm getting program loading necessary on radio, unfortunately car didn't come witgh the ad card. damn you subaru!!!
Lol I called it! Glad to hear everything is working

Sent from my iPhone using Tapatalk
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.