Subaru WRX Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I was noticing my car wouldn't hold boost so I checked everything. Found a hole in an Intercooler coupling, repleaced it and same thing happens. Switched BOV's Boost controllers and even intercoolers and it still won't hold boost. When I drive it it will boost to 16.5psi the drop to anywhere it feels like anywhere between 8 - 12psi. It will never hold fullboost in any gear. Any ideas? I think it might be an uppipe leak, would that do it?
 

·
Registered
Joined
·
389 Posts
ImprezaWRX02 said:
I was noticing my car wouldn't hold boost so I checked everything. Found a hole in an Intercooler coupling, repleaced it and same thing happens. Switched BOV's Boost controllers and even intercoolers and it still won't hold boost. When I drive it it will boost to 16.5psi the drop to anywhere it feels like anywhere between 8 - 12psi. It will never hold fullboost in any gear. Any ideas? I think it might be an uppipe leak, would that do it?
You sound like you're having the same problem as me. Do a search for threads I started, you'll see it. I think its my BOV that's doing it. I don't get any readings though because my boost gauge tap is before my BOV. I'm changing it back to stock soon so I'll let you know if thats it.

-Blue
 

·
Registered
Joined
·
12 Posts
I don't think where your boost gauge is tapped in affects the reading. It measures the vacuum in your vacuum system, and therefore if you really are leaking boost from your BOV it would see it no matter where it's hooked up.
 

·
Registered
Joined
·
181 Posts
Question to GOD

God,
I have Vf22.
I can not hold boost either. Mine hits 18psi and drops to like 14psi around 6k rpm.
I'm turboXs stage 4 with vf22. What could be a possible prb.?
Thanks in advance.
-soul
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #9 ·
God, I have a stock turbo. But before At redline I could still hold around 14 psi but now no matter what rpm i'm at it will hit 16.5 and almost immediatly fall straight back down to around 8-11psi.
 

·
Registered User
Joined
·
1,911 Posts
Hmm, what are you guys using for boost control? Check all your clamps to make sure they are tight. On a stock car or mostly stock car we rarely see a problem. If you're using stock selenoid try replacing the T at the turbo lines as sometimes that causes a little lower boost.
 

·
Registered
Joined
·
1,329 Posts
I have a Stock turbo on the stock boost controller with a catless system and I still go from about .95 mpa to .6 to .7 mpa depending on which gear I am in. The stock turbo just doesn't hold boost that long, it starts droping around 5.5k rpm's.
 

·
Registered
Joined
·
9 Posts
hippy78 said:
lol, I have the opposite problem:).. My car hits boost upto about 5200rpm, then creeps to red line(with a vf34)....
Sounds like you need a new/better wastegate or you need to check for leaks on your line.
 

·
Registered
Joined
·
389 Posts
JustChou said:
I don't think where your boost gauge is tapped in affects the reading. It measures the vacuum in your vacuum system, and therefore if you really are leaking boost from your BOV it would see it no matter where it's hooked up.
Yeah I thought that too, and it makes sense. Let me give you an example. this isn't just a reading observation. I CAN'T REDLINE SECOND GEAR OR ANY HIGHER! Once I hit like 4k in second, my RPMs just wabble and make this weird pulsing feeling. It just started a little while ago. Also, once I hit a certain boost, I just hear a whooshing noise, like a constant blow-off of boost. I'm definitely loosing boost somewhere and its PISSING ME OFF!!!

Once that BOV comes off, if its still doing it, im hoppin over to Subaru:mad:

-Blue
 

·
Registered
Joined
·
18 Posts
I see that this is a perty old thread but regardless i have an 04 with the same issue it wont hold boost. Im wondering if any of you guys were able to find out and fix the problem?
 
1 - 15 of 15 Posts
Top