Subaru WRX Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
I have 2003 Subaru Wrx .
I just got onto the highway doing about 70 and i went to accelerate to get up to speed(75) and i noticed no go when i pushed the gas pedal, i looked at my tach and it was at zero even though i was in 5th gear, i down shifted into 4th maybe seeing if she would start back up and no luck, i pulled over and tried to start her and she didnt. check engine light was on before. she cranks but she dont start, i tried to hook up an obd 2 scanner and it wont connect to the computer, when i turn the key to the on position, every light lights up on the dash but the check engine light, and the fuel pump does not come on either.

Checks all fues and relays they all good , fuel pump not getting ground , both wires on fuel pump was getting power which makes me think I have short somewhere .. so I changed the fuel pump controller. N the wire that should be ground for fuel pump from controller is getting power .. so I cut that n connect to the ground .. now fuel pump turns on .. while key is on position. But it doesn't turns off .. when tho car is not on .. and the car cranks but doesn't turn on .. any ideas what eals I should check plz

Any ideas? thanks
 

·
Super Moderator
Joined
·
11,124 Posts
How did you have zero rpm while in gear on a manual? Something strikes me as an electrical issue. Ground, bad ECU, frayed harness.

Sent from my SM-G955U using Tapatalk
 

·
Super Moderator
Joined
·
11,124 Posts
Ok, I understand that. My question is about the tach reading zero while moving and in gear


Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
2,101 Posts
How did you have zero rpm while in gear on a manual? Something strikes me as an electrical issue. Ground, bad ECU, frayed harness.
:yeahthat:
 
1 - 8 of 8 Posts
Top