Subaru WRX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
129 Posts
Discussion Starter · #1 ·
See video link, sound started up a couple days ago, not present at idle/neutral whether clutch is depressed or engaged, Only heard when moving, whether it's acceleration or coasting in neutral. Sounds like it's coming from the front passenger wheelwell, or possibly that side of the engine bay. No clue what could be causing it, can't see any visible causes either. Gonna be taking off my wheel tonight to see if I can figure it out, have an appointment set with the dealership this coming Thursday at 7:30AM but figured I'd crowdsource in case anyone knows. Thanks in advance for the help.


volume is kinda quiet, and ignore the turn signal. metallic type clicking/pinging
 

·
Super Moderator
Joined
·
11,736 Posts
What have you done to diagnose?

Does the sound change with vehicle speed or rpm changes? Does anything make it worse or better?

Things I look for are objects in the tires or caught in brake dust guards, things hanging like wiring looms or objects picked up from the road. If its only while moving I would look around all of the rotating parts.
 

·
Registered
Joined
·
129 Posts
Discussion Starter · #3 ·
What have you done to diagnose?

Does the sound change with vehicle speed or rpm changes? Does anything make it worse or better?

Things I look for are objects in the tires or caught in brake dust guards, things hanging like wiring looms or objects picked up from the road. If its only while moving I would look around all of the rotating parts.
Sound doesn't really change with increase in speed or RPM, most noticeable when moving at a low RPM, but that's probably because of my exhaust. Not present at all while in idle/stationary, and not present if I just give it a bit of gas while in neutral. Though I think we determined it's the heat shield coming a bit loose. Will check the rest of the rotating parts as well just to be safe
 
1 - 4 of 4 Posts
Top