ClubWRX Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys need some help. Installed a turbo back exhaust system yesterday. There is a small amount of smoke and burning oil smell coming from the exhaust. Is this normal? It’s a 2004 wrx. No smoke or burning oil smell when stock system was on. Any help would be appreciated as it’s freaking me out a lot. Doesn’t happen under power only when coming to a stop
 

·
Premium Member
Joined
·
10,932 Posts
When do you see the smoke? All times? Just during start up? Is it oily?

Performance catalytic converters are kind of like filtering water with an empty strainer. Sure they stop something but not really.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
When do you see the smoke? All times? Just during start up? Is it oily?

Performance catalytic converters are kind of like filtering water with an empty strainer. Sure they stop something but not really.
Only when I’m slowing down for a traffic light. Other than that it doesn’t smoke
 

·
Premium Member
Joined
·
10,932 Posts
You can see it from the cabin? Temperature and vehicle temp doesn't matter?

Rule of thumb blue smoke is oil, white is water, black is fuel. Check your fluid levels and see if it's burning oil or coolant.
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,063 Posts
Was the exhaust coated for shipment and storage? Did you spray the bolts with penetrating oil before replacing the old components?
 
1 - 7 of 7 Posts
Top