Subaru WRX Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 · (Edited)
Boost Problems??? I need yu guys

Ok b4 anyone says anything, yes ive already searched about this topic and have read mostly all threads. Ok i installed my joe-p mbc about 2 weeks ago and was boosting 15.5 in all gears. Went to the track and ran a 13.7 so everything was fine until i looked under my hood and saw that my forge blow off valve was loose. Since i first installed the mbc i had a loud whine almost like a supercharger and thought it was normal cuz installed mbc but when i tightend up the blow off valve the noise went away. The problem is that a couple days after my nob for the mbc came off and the guys at joep.com told me it was cuz i was overboosting but my boost gauge was only reading up to 9 psi. Got a new nob hooked it up and still only getting 9 psi but then i took off mbc and reinstalled fbc and went up to 11 or 12 psi. So i dont know what to do anymore so can i please get any suggestions. peace out gabe
 

·
Banned
Joined
·
601 Posts
weird. I have no clue. First thing I would jeck though, would be the boost gauge installation. If the joe p people are sayin you overboosted, and you only saw 15.5psi, that just sounds fishy to me. Some boost gauges come with a y fitting that has a restrictor in one side of them(which goes towards the gauge). Maybe if the y fitting isn't in the right direction, or if a different fitting was used, the boost gauge isn't working right? This might also break the gauge? I dunno. After checking the gauge(maybe by putting some compressed air in the hose or using another gauge), I'd try opening the mbc up til I hit the right boost too. If the boost doesn't go up, I'd try a different boost controller. If all else failed, I'd check the vacume lines on the turbo to make sure the restrictor is still in the right line.

If while installing the boost controller, the vacume line on the turbo with the restrictor in it was removed, then the mbc would have a lot more air to vent to be able to make the boost you are shooting for. That could also be the broblem. If it is, and you don't still have the restrictor, you an get one from subaru... If all those things are cool, I'd then check to make sure the wastegate is closing all the way... I dunno what else to say...

peace

peace
 
1 - 4 of 4 Posts
Top