Subaru WRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just put on the big sf intake, and flashed the Cobb Stage 1+ tune. I'm worried about running lean and damaging the engine. My AF learning is at 14 consistently while in cruise, and maybe around -5 in idle. I'm new to this, so I'm having a hard time deciphering if this is bad. WOT it zeros out. Can anyone help, or give me your thoughts on this? The car is only at 20k, so I don't think the MAF is dirty. My DAM has also dropped to .87. I do plan on eventually getting an etune.
 

·
Æternum
Joined
·
15,555 Posts
When did you install the SF intake?

The SF is an oiled filter. In my recent experience, the MAF will need to be cleaned pretty quickly (within 1000 miles) after installing the filter due to the oil deposition onto the hot wire.

I would clean the MAF first (since it's so easy), reset the ECU and drive a bit. If the DAM drops again, start searching for vac leaks.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
When did you install the SF intake?

The SF is an oiled filter. In my recent experience, the MAF will need to be cleaned pretty quickly (within 1000 miles) after installing the filter due to the oil deposition onto the hot wire.

I would clean the MAF first (since it's so easy), reset the ECU and drive a bit. If the DAM drops again, start searching for vac leaks.
Wow, thank you so much! I didn’t think about the oil. Just put it on this weekend. I cleaned the sensor, and so far the numbers are looking much more reasonable!
 
1 - 3 of 3 Posts
Top