ClubWRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
If you don't want to read my wonderful narrative, you can skip to the cliffsnotes at the end.

I went out today to do a little ECU logging and noticed a peculiar issue. While I was slowing down for a stop sign, I heard a bang like I hit a pothole or something, but when I looked back, I saw nothing. It definitely came from the right side. I've also noticed some brake squeaking too that's been around since I had the passenger side drive axle replaced but today, I think it got worse. Since that was the last thing to be apart, I thought I would take the wheel off and see if I could spot anything wrong. The only thing I could find was one of the wheel studs needs replacing. Anyway, I torqued the wheel back on to the owner's manual spec and took it for a test run. I pulled out of my driveway, and as soon as I hit the brakes coming up to the first stop sign (ever so slightly) *BANG*. I turned around, pulled into the driveway for another quick inspection, saw nothing, so I tried again. Same thing.

This only happened once or twice on a drive, usually at the beginning of it. I've wanted to replace all the pads & rotors since I got the car but haven't got around to it yet.

Cliffsnotes: Brakes squeaking more than usual. Occasional banging sound when brake pedal is pressed. :dontknow:

Any ideas?
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,445 Posts
The method to replace axles that I like doesn't mess with the brakes, the whole strut is just flopped aside or hung from a wire etc. Is the axle nut on and is the tab hammered to keep it in place? Could the brake disc shield be hitting something, maybe it got bent? On the other end of the axle there is a pin to keep it in. Is the pin there?
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
29,445 Posts
Something else: Are you sure the pads are OK, and that there is no leak to soak them with fluid?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
The method to replace axles that I like doesn't mess with the brakes, the whole strut is just flopped aside or hung from a wire etc. Is the axle nut on and is the tab hammered to keep it in place? Could the brake disc shield be hitting something, maybe it got bent? On the other end of the axle there is a pin to keep it in. Is the pin there?
The axle nut is in place with the keeper notch hammered in. I didn't take a good look at the shield so I'll have to check it again. I'll also check the axle pin when I get a chance.

Something else: Are you sure the pads are OK, and that there is no leak to soak them with fluid?
I didn't notice anything leaking, I'll check the pads again sometime this week.
 
1 - 4 of 4 Posts
Top