Subaru WRX Forum banner

1 - 20 of 36 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hello everyone my name is William I am a technician and I have a 2013 wrx and having a hard time narrowing down whats wrong with my car. the issue that I am having is that under low load cruising and i would say 30-40% throttle i get a feedback of -1.4 to -11.8 on a daily basis and i cannot find out why and i need help.
Mods include
Grimmspeed tmic
Grimmspeed ebc
Forged diverter valve
DW 1000cc injectors
DW65c fuel pump
Cobb intake
1 step colder plugs
Invidia downpipe
Tsudo exhaust
Custom Stage 3 tune from torqued performance.
Ive already sent data logs to Eric at Torqued Performance and he told me everything on the tune still looks good. I pulled spark plugs out to inspect them and they look great. Checked for any loose heat shields and made sure my knock sensor was tight and nothing was near it causing a false knock. I'm at a loss and don't know if something mechanically is wrong. This started after i put gas from another gas station that i normally use but i made sure my tank was clean and i have ran through 4 tanks of gas already. i pulled my pump out to inspect it and found nothing after that i took a fuel sample and it showed about 12 ethanol and i figured it was that but had no luck after that. under boost the car runs great but cruising is the only issue. Any advise would be appreciated!
 

·
Registered
Joined
·
24 Posts
I would start there if you did install them straight out of the box then you are probably not consistent across all cylinders should be .27-.29

Sent from my SM-G930V using Tapatalk
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #8 ·
I installed these plugs maybe 10 months ago. ill check and see what they are just to make sure its gonna be a little bit before i get an answer because I'm leaving work now and i may look at them when i get home if the motor is not too hot.
 

·
Registered
Joined
·
24 Posts
I installed these plugs maybe 10 months ago. ill check and see what they are just to make sure its gonna be a little bit before i get an answer because I'm leaving work now and i may look at them when i get home if the motor is not too hot.
Also check the color of the plug may give an indication as to what is going on in the cylinder if anything

Sent from my SM-G930V using Tapatalk
 
1 - 20 of 36 Posts
Top