ClubWRX Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
'06 WRX TR


I ask because my car has been at the dealership for 2 weeks now (again) and they say the problem is a bad air flow meter. Never heard of such a thing and I tried google to learn a little but all that'd come up is MAF sensor information.

The reason this concerns me is that they are so sure that is my problem but if it is the MAF sensor he means then I have high doubts since I've replaced it twice already (first time with Autozone part second from the dealership).

I didn't get to ask him about it because he left me a voicemail as he was on his way out for the night so I have to wait until tomorrow to talk to him. Figured why not ask the experts, you all are good at teaching us newbies things.
 

·
Premium Member
Joined
·
10,943 Posts
I would suppose so.. MAF stands for "Mass Air Flow", and it measures the amount of air drawn through the intake.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
That makes sense. Guess I'll be having a fun chat with him tomorrow about why he's wrong lol.

Thanks much!
 

·
Good news, everyone!
Joined
·
3,856 Posts
Which dealership did you take it to?
 

·
Good news, everyone!
Joined
·
3,856 Posts
Ah, let me know how that turns out for you. I have experience with the 3 dealerships in the SL valley, but none outside the valley. Nate Wade is by far the bottom of the list for places I would go to have my car worked on if I really needed it.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #7
I'm glad you said that because I was actually thinking of having Nate Wade take a look at the POS for me. Glad you saved me the time I would have wasted getting it down there and arranging rides home and stuff!
 

·
Registered
Joined
·
6,751 Posts
Do you have any mods to the car?

Most of the time a "bad" MAF just needs to be cleaned with a $5 can of electronics spray cleaner. At a certain point they can get dirty enough that they do break though.
 

·
Good news, everyone!
Joined
·
3,856 Posts
He's been going through his issues for many months there Scott, he has a couple of threads about it. :)
 

·
Registered
Joined
·
6,751 Posts
Oh wait a second yeah it's zarlan he of the car with mysterious issues that nobody can figure out. :)
 

·
Premium Member
Joined
·
10,943 Posts
I might have to read the threads tomorrow.. god knows I've dealt with plenty of "mysterious issues" with my car.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #14
Ok picked the car back up as after all this time I'm low on $$$.

They pulled a MAF off another customer's car (04 WRX) and it fixed the problem. Put his part back in and sent him on his way while ordering me a new MAF... again.

New MAF did NOT fix the problem, on the Subaru select monitor the MAF is going off the scale lol.

So.... I dunno what to do, anyone wanna write me a nice SD map for a completely stock car to just bypass the MAF?
 

·
Premium Member
Joined
·
10,943 Posts
Hmm.. have you tried cleaning up all the grounds? A lot of times when a sensor is acting screwy it's due to poor grounding. Another thing I would try is swapping the ECU. I remember a while back there was this guy having weird problems, and after years and lots of money spent diagnosing to no avail he swapped ECUs and it was fixed. Apparently water had leaked in through a grommet in the firewall and damaged the ECU just enough to make it run weird.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #16
Yeah the grounds have been cleaned up. Swapping ECU may be something I'll try but won't I need Subaru to program it to match the immobilizer?
 
1 - 20 of 30 Posts
Top