Subaru WRX Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
ok I am new but hear me out. I have headers and uppipe and the front o2 sensor will not screw in properly due to oversizing of the up pipe. evedently the o2 sensor tip rests against the piping? does this make sense? Anyways I had this done when i replaced my motor... another story... Damn oil pump! they told me this so the front o2 sensor is not in and plugged. I have the access port and i am assuming this is why i am not getting air fuel ratio. What can i do to fix this? Are there aftermarket o2 sensors? do i just weld the thing in there? most importantly will this screw up my car. The thing runs like a bat out of hell.
 

· Super Moderator (Actually a SuperSpy)
Joined
·
30,450 Posts
ok I am new but hear me out. I have headers and uppipe and the front o2 sensor will not screw in properly due to oversizing of the up pipe. evedently the o2 sensor tip rests against the piping? does this make sense?
Not to me, no. In what pipe does the sensor belong? The up pipe or the headers?

I have the access port and i am assuming this is why i am not getting air fuel ratio.
Does the car generate a CEL? Use the AP to read the code and post it.

(I'm avoiding asking "what do you mean by 'not getting air fuel ratio'" specifically for now until I figure out which sensor in which pipe is giving you trouble).
 

· Super Moderator (Actually a SuperSpy)
Joined
·
30,450 Posts
There is no 02 sensor in the up pipe.

There is an EGT sensor in the up pipe that the car uses to warn it in case the cat con that was in the factory up pipe is failing or stuffed.

So, are you getting a CEL?

Also, are you getting a CEL?

You will eventually get at least one CEL, since the EGT is no longer connected. You may get more than one for all I know -- I don't know what else is done to your car with enough details. This can be fixed either by using a resistor (search resistor mod) or by addressing it via the AP; which course you take should depend on how your particular state tests emissions and whether you need all sensors to report "ready" to pass emissions testing.
 

· Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
no lucky for me i don't have emissions! I do have cel and tryed to clear with ap but it won't... I really just don't want the thing to blow up run lean. the afr doesn't change but i believe the ap controls this so should i be worried? Sounds like my rear o2 may be bad
 

· Super Moderator (Actually a SuperSpy)
Joined
·
30,450 Posts
Please re-read my posts and try to answer the questions.

What is the CEL code?
What specific mods have been done to the car?

Search here for a diagramme showing the exhaust system. If I happen to find it I'll link back to you. This will allow us to call everything the same name so we each know to what the other is referring.

EDIT: here:
http://www.clubwrx.net/forums/engine-modifications/134326296-exhaust-intake-flow-confusion.html

Now, is the "02" sensor you are talking about initially the part that is labeled "temperature sensor" in the diagramme? That's the EGT. Address that issue either way described.

Does the car have headers, now that you have seen the diagramme? What parts were replaced with the headers? What headers were used? What map is being run with the AP and do your parts correspond with the map?
 

· Super Moderator (Actually a SuperSpy)
Joined
·
30,450 Posts
Here are the mods you listed for ease of viewing:
"Engine/Transmission mods
turboXS tmic hksbov, 550cc inj, spt intake, header, uppipe, hks downpipe, (No Cats), mishimoto alum rad, sti timing belt, fidandza flywheel, act 6 puck clutch, Cobb Accessport stage 2 pro tune, upgraded walbro fuel pump, turbo back exuast, lgt 1-4 gears."

So the car has a custom tune. OK. Again, you should be able to deal with an EGT CEL one of two ways.
 

· Super Moderator (Actually a SuperSpy)
Joined
·
30,450 Posts
Yet the front O2 sensor is in the header, not the up pipe.

Pls confirm whether you cannot fit a sensor in a bung in the up pipe or the header.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top