Subaru WRX Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2011 Subaru wrx premium sedan and the ac does not work. I went through the AC Self Diagnosis from the service manual to find that nothing seems to be wrong electrically... I think. The car will not tell the clutch to engage. I used a power probe to engage the clutch from the plug right on the compressor. I also replaced the a/c relay. I checked the valve and there's no pressure so I will for sure have to refill the Freon. However, I am nervous about the noise its making when I engage the clutch with the power probe. It's almost a buzzing noise, possibly a bad bearing maybe? Does this give any clues to anything else I might need to fix? I don't want to refill the Freon just to redo it all again.
 

·
Super Moderator (Actually a SuperSpy)
Joined
·
19,584 Posts
Is there a mess around the compressor? If you have no pressure, you have a leak. You need to find and fix the leak regardless of any other damage.

There is a roller on the front of the engine that sometimes goes bad, it's like a $30 pulley and if you hear bearing noise maybe that's it instead of the AC compressor (I'm assuming you didn't remove the belts individually to test).

In any case, verify you have zero pressure and find the leak. If the leak is at the compressor, there's your answer. If it's elsewhere, you'll have to fix the leak before getting enough pressure in the system for the compressor to engage due to the low pressure switch anyway.
 

·
Registered
Joined
·
47 Posts
R134a does not evaporate. There is a leak. I suggest not using a powerprobe unless you are proficient in automotive electronics, it can make alot of trouble with the press of a button. Putting power to the ac clutch verifies it's not seized (engaged to disengaged). It will never engage without enough refrigerant. Follow ac lines, look for dust or dirt build up. It does not evaporate....also, the compressor /clutch making odd noises when it's empty might be caused by lack of refrigerant oil that leaked out where the r134a leaked out
 

·
Registered
2012 Subaru Impreza WRX Premium 5-Door 2.5L Turbocharged 5-Speed Manual
Joined
·
64 Posts
If the system is low or empty the oil will not circulate properly and the compressor will make noise just like an engine with no oil. Best thing to do is, if dye has been added at any point, use a UV light to look for any leaks. Pull the belt and check the compressor shaft for play or bearing problems/noise. Otherwise, you'll have to find a leak by either charging the system with dye added and look for leaks that way and hope you didn't cause any damage forcing the compressor to run.

I recommend taking it to a shop that does reputable AC work, explain your issues and the steps you have taken thus far and have them figure it out. Proper service equipment will be required.
 
1 - 4 of 4 Posts
Top