ClubWRX Forum banner

1 - 20 of 40 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
Well I am sad to say I need to get rid of the Evo :( 108 degree temps and humidity = death to a turbocharger. I am experiencing such bad lag, it feels like I am trying to take off in 3rd gear, not to mention I am getting really tired of the $600 monthly payments.

So now I have my eye on some used cars. I am trying to decide between a 1998/1999 Camaro Z28 and a 1992-1996 Corvette. They both carry the same 5.7L LS1 engine, the Camaro puts out 305 hp and the Vette puts out 300 hp (330 hp in the 96) Believe it or not, the Camaro is actually quicker then the Vette by about half a second in 0-60 and the 1/4 mile. The Camaro would run me $8K-$11K depending on condition and miles while the Vette would be more like $12K-$15K. Any recommendations? Which one would you go for?
 

·
Registered
Joined
·
275 Posts
Discussion Starter #6
Stumbo said:
Some 4th gen f-bodys came with LS1s... All 4th gen Vettes came with LT1s...

Get a 98 or later F-body.

May the flaming beginith.
Actually, we are both wrong. The 1984-1991 Vettes carried the L98, the redesigned LT1 "Gen II" smallblock V8 was used from 1992-1995 and then the LT4 made an appearance in 1996 in the final year of the 4th gen Vettes. The LS1 was used from 1997 on.

For the Camaros, the LS1 was used from 1998-2002.
 

·
Registered
Joined
·
19,615 Posts
either car is much MUCH more classy than the Evolution 8
600 a month?!?!?!
damn, son
any down on that car?
go with the 'Maro. can't beat it:thumbup:
 

·
Registered
Joined
·
275 Posts
Discussion Starter #8
Ya, I put down $8K. I am leaning towards the Camaro, I just read you can get about 500 hp (425 whp) out of that LS1 with only about $3-$4K in mods :eek:
 

·
Registered
Joined
·
19,615 Posts
EVOVIII said:
Ya, I put down $8K. I am leaning towards the Camaro, I just read you can get about 500 hp (425 whp) out of that LS1 with only about $3-$4K in mods :eek:
you put down 8k and your payment was still 600 a month??!!?
damn, son....does your credit bloww ?
let's not forget that putting 500hp in the LS1 was probably from a 'newer' block
I don't trust terribly used muscle. you KNOW it's been beaten
 

·
Registered
Joined
·
275 Posts
Discussion Starter #14
Well, lets do the math here. My payment is actually over 600 a month so here is the breakdown. The price of the car was $32K and I put down $8K which meant I had to finance $24K. They do not lease Evo's, you have to buy them and they very rarley do 5 year deals, 95% of them are 3 years. That mean I have to pay $24K over 3 years which is $8K a year. That puts your payments over $600 a month which is what I pay. The only people who pay under $500 a month for their Evos are the ones who put down half of the price as a down payment, I only put down a quarter.
 

·
Registered
Joined
·
438 Posts
My evo Runs Fine in the heat, I have even raced with the A/C on and it STILL runs good. My guess is that you have a boost leak, minor one, disconnect your battery, tighten all your clamps as heard as you can and try again. My evo felt Kinda slow when I got it, I did this, picked up extra 4PSi of boost. Maybe get a Dyno flash too.
 

·
Registered
Joined
·
27,068 Posts
wrxlude said:
either car is much MUCH more classy than the Evolution 8
anyone who calls a camaro "classy" should be beaten up in a dark alley.

I would go with the camaro over the vette, but i wouldnt buy the camaro either.

what other cars have you considered... i dont want to start a domestic vs. import thing here, but truthfully, a camaro is not the most reliable car, especially used... theres a VERY LARGE chance, someone beat on it.

although its more money, i think the ws6 is worth the extra cash...
have you thought about a cobra or newer GT? or maybe a GSX eclipse.

gsx can be made for low 13's VERY EASY.
cobra is a bit nicer than the camaro, IMO... but not that much.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
275 Posts
Discussion Starter #20
Evilevo8 said:
My evo Runs Fine in the heat, I have even raced with the A/C on and it STILL runs good. My guess is that you have a boost leak, minor one, disconnect your battery, tighten all your clamps as heard as you can and try again. My evo felt Kinda slow when I got it, I did this, picked up extra 4PSi of boost. Maybe get a Dyno flash too.
Well you are in NJ and I know you don't see any 112-115 degree days out there so there is no comparison. I'm getting tired of tthe sky high payments too.

As far as the Trans Am goes...its the same exact car as the Camaro but its about $2K more expensive because there were less made, I would much rather have the Chevy but thanks for the thought.
 
1 - 20 of 40 Posts
Top