ClubWRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hello, and thank you in advance my subie family.
So.. for awhile in my new 2019 wrx had it 1.5 years now.
Had been experiencing vibrations and hard to go thru the gears while driving. The clutch vibration was very noticeable when engaging. Took it to dealer. Only 23k miles. Under warranty still. They said they didn't find anything. Then a second time they kept the car one day over night. Gave me a receipt that they've replaced throw out bearing. Still had the vibrations. Ignored it. Still lots fun to drive.
4 days ago. While climbing out of my driveway small grade hill the car started pulsating while hill assist was on. Took it back to dealer. This time they actually did replaced a whole bunch stuff. Including TB. But now I have no power or torque..what should I do...I wanna take it to Brent tuning to have them look at it.
Thanks
 

·
Æternum
Joined
·
15,142 Posts
Take it to a different dealership.

Taking it to a tuner will not solve your problem and potentially violate elements of your warranty. If this is a problem with the car under warranty (and the car is unmodified), it is Subaru's problem to address it.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Take it to a different dealership.

Taking it to a tuner will not solve your problem and potentially violate elements of your warranty. If this is a problem with the car under warranty (and the car is unmodified), it is Subaru's problem to address it.
Hi, thanks for replying.
The car has all the safe not warranty voiding mods. Kartboy short throw, street aig aos, Cobb 3" cat bak and. I'd made sure all was safe with the warranty. The car suddenly has no ponies. I've push the turbo to 17.5 psi. Nope torque nothing..all my radio and miles. Temp trip miles are there. So I don't think they'd pulled the negative terminal on the battery.
 
1 - 3 of 3 Posts
Top