Subaru WRX Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

1st post here. Been searching for my issue with no luck. After having my 2018 WRX Base CVT for about 2.5 months with about 15000km on the car all of a sudden one day when I turned on the defrost I got a really strong rubber/chemical/oily smell from the defrost, when switched to floor vents no smell coming in. Upon getting home I could smell the same stink outside the car only near the front passenger area, when opening the passenger door the odour was stronger from the area near the door hinges into the fender area. Don't smell it on the drivers side from the outside of the car. I am at almost 21000km now. It lasted a bit, went away and comes back periodically, last night when our temps went up (located in frozen northern Ontario) to about 9C or about 45F the smell came back really strong. It actually makes me sick with a typical allergic type reaction.

The car was undercoated about a month before the 1st time this occurred at a Subaru dealership, never had any issues at that time. Suspected it was the undercoating but being only obvious on one area of the car this makes no sense. I wiped a bunch of the coating with a rag and brought it inside and put it in a box to see if the odour was present, it was not.

Had the car up on a hoist 2x looking for leaks or any kind of plastic or other mess that doesn't belong there and nothing was found. Had other eyes besides mine looking also.

When the heat is on re-circulate it is barely noticeable if at all.

Have not gone to local dealership as they were so terrible I drove 150km out of town to buy the car at a different dealership.

It is not the car off-gassing, it is well past that point and this is a specific odour that is in one area of the car and only comes through the defrost and only sometimes.

Has anybody here experienced anything like this????

I like the car otherwise!!
 

·
Registered
Joined
·
63 Posts
Normally people get a smell when the engine finally bakes-in when it gets hot, but you're discribing something different.
I hope someone has a solution or root cause for you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I should also note that I have checked the cabin air filter, it is fresh and clean.

I have driven the car quite hard, many many launches up to 100mph + and heated things up really well. The car a has been driven to the point of severe brake fade on twisty roads where it pulsed like it was having a seizure under light braking which returned to normal after a few mins each time. The point of adding this is that it smells like burning hot goodness after this type of driving. The smell I am getting is not related to this type of driving.
 
1 - 3 of 3 Posts
Top